Debugger menu item wrongly ticked

RESOLVED DUPLICATE of bug 764625

Status

()

Firefox
Developer Tools: Debugger
P3
normal
RESOLVED DUPLICATE of bug 764625
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
1. Open Firefox with a new profile
2. Go to Firefox > Web Developer > Debugger. The debugger pane is open and the Debugger menu item is ticked
3. Open a new tab. The Debugger menu item is still ticked while it shouldn't.

Comment 1

6 years ago
(In reply to Scoobidiver from comment #0)
> 3. Open a new tab. The Debugger menu item is still ticked while it shouldn't.

The same behavior is applied for the Web Console. I think this is the expected behavior by design: the Debugger/Console is open in the browser, so it's ticked in the menu. Isn't the menu for the whole browser, and not tab specific?
(Reporter)

Comment 2

6 years ago
The Web Console, Inspect, Responsive Mode and Debugger tools are per-tab specific, so the matching menu item should be ticked based on the displayed tab.

(In reply to Ioana Budnar [QA] from comment #1)
> The same behavior is applied for the Web Console.
It's another bug. It seems that bug 719850 has been canceled elsewhere.

Comment 3

6 years ago
(In reply to Scoobidiver from comment #2)
> The Web Console, Inspect, Responsive Mode and Debugger tools are per-tab
> specific, so the matching menu item should be ticked based on the displayed
> tab.
> 
> (In reply to Ioana Budnar [QA] from comment #1)
> > The same behavior is applied for the Web Console.
> It's another bug. It seems that bug 719850 has been canceled elsewhere.

Thanks, Scoobidiver. It seems that only the Debugger and the Web Console have this issue. The other two are working fine. 

I see that you reported bug 719850 too. Considering that it still reproduces, do you know if the fix for it worked? Should it be reopened, or should a new bug be filed?
(Reporter)

Comment 4

6 years ago
(In reply to Ioana Budnar [QA] from comment #3)
> Should it be reopened, or should a new bug be filed?
It's bug 759384.
Priority: -- → P3

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 764625
You need to log in before you can comment on or make changes to this bug.