[Page Thumbnails] No thumbnails created for certain websites: distrowatch, imageshack, twitter, ...

RESOLVED DUPLICATE of bug 756881

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 756881
6 years ago
6 years ago

People

(Reporter: omeringen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Nightly is unable to create thumbnails for some websites like distrowatch, imageshack, twitter. . . Cleaned thumbnails folder and cache, no difference.

Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1

Updated

6 years ago
Summary: unable to create thumbnails for specific websites → No thumbnails created for certain websites: distrowatch, imageshack, twitter, ...

Comment 1

6 years ago
Here is an IRC log of a conversation with omeringen, which may clarify the bug:

Jun 02 16:40:09 <omeringen>	hey
Jun 02 16:40:21 <omeringen>	could someone please make a test about : https://bugzilla.mozilla.org/show_bug.cgi?id=760773
Jun 02 16:40:39 <omeringen>	on a Win64 build ?
Jun 02 16:40:56 <omeringen>	i filled that bug for Linux only
Jun 02 16:57:36 <rindolf>	omeringen: I will need to boot into Windows.
Jun 02 16:57:53 <rindolf>	omeringen: must it be Win64 or can it also be Windows 32-bit?
Jun 02 16:58:07 <omeringen>	okay, because i believe it not a linux related issue
Jun 02 16:58:16 <rindolf>	omeringen: and you should provide a better method to reproduce it.
Jun 02 16:58:21 <rindolf>	omeringen: what?
Jun 02 16:58:32 <rindolf>	A more methodical method.
Jun 02 16:58:41 <rindolf>	Your bug report is short of details.
Jun 02 16:58:42 <omeringen>	rindolf,  there is no a special way. . . there is just NO thumbnails at all for this websites
Jun 02 16:59:00 <rindolf>	omeringen: by thumbnails do you mean the favicons to the left of the address bar?
Jun 02 16:59:11 <rindolf>	Or the ones appearing in the bookmarks menu?
Jun 02 16:59:12 <omeringen>	thumbnails for new tab feature
Jun 02 16:59:25 <rindolf>	omeringen: I don't understand.
Jun 02 16:59:30 <rindolf>	omeringen: what are thumbnails?
Jun 02 16:59:33 <omeringen>	don't you know new tab feature ?
Jun 02 16:59:39 <rindolf>	omeringen: no, I don't.
Jun 02 16:59:50 <omeringen>	oh okay :) 1 min pls
Jun 02 17:00:15 <rindolf>	omeringen: https://wiki.mozilla.org/Firefox/Features/New_Tab_Page - this?
Jun 02 17:00:25 <rindolf>	I've been using Firefox 10 ESR here.
Jun 02 17:00:40 <omeringen>	https://wiki.mozilla.org/Firefox/Features/New_Tab_Page
Jun 02 17:00:45 <omeringen>	yep
Jun 02 17:00:48 <rindolf>	OK.
Jun 02 17:01:07 <omeringen>	if you can check latest nightly, it would be really good
Jun 02 17:01:10 <rindolf>	omeringen: OK, let me try it on my Win32 VM.
Jun 02 17:01:15 <omeringen>	ok

Comment 2

6 years ago
OK, I can reproduce it on my Windows XP SP 3 VM with the "Nightly" version of firefox - neither distrowatch.com nor twitter.com display any thumbnails/previews after they are placed into the "New tab" displayed sites. It seems like a serious bug.

Regards,

-- Shlomi Fish
(Reporter)

Comment 3

6 years ago
I made a test on WinXP SP3 x86. Looks like it's not a platform dependent issue.
OS: Linux → All
This is related to bug 756881 (maybe a dupe) and probably caused by bug 754608. Do all of these pages send the 'Cache-Control: no-store' header?
Hardware: x86_64 → All
Summary: No thumbnails created for certain websites: distrowatch, imageshack, twitter, ... → [Page Thumbnails] No thumbnails created for certain websites: distrowatch, imageshack, twitter, ...
(In reply to Tim Taubert [:ttaubert] from comment #4)
> This is related to bug 756881 (maybe a dupe) and probably caused by bug
> 754608. Do all of these pages send the 'Cache-Control: no-store' header?

Looking at the header using the WebConsole I find: 

Response Headers
    Δ148ms
  
  X-Powered-By:PHP/5.3.3-7+squeeze9Transfer-Encoding:chunkedSet-Cookie:NewLastSeen=7281; expires=Tue, 12-Jun-2012 19:52:56 GMTServer:Apache/2.2.16 (Debian) mod_ldap_userdir/1.1.17 PHP/5.3.3-7+squeeze9 with Suhosin-Patch mod_perl/2.0.4 Perl/v5.10.1Pragma:no-cacheLast-Modified:Sat, 02 Jun 2012 20:52:56 GMTKeep-Alive:timeout=15, max=100Expires:Mon, 26 Jul 1997 05:00:00 GMTDate:Sat, 02 Jun 2012 20:52:56 GMTContent-Type:text/htmlConnection:Keep-AliveCache-Control:no-store, no-cache, must-revalidate, post-check=0, pre-check=0

This on the Distrowatch.com site.  So does appear its using 
'cache-control: no-store'  

Note: I'm not anywhere near expert on reading this stuff - just stumbling around.
(Reporter)

Comment 6

6 years ago
(In reply to Tim Taubert [:ttaubert] from comment #4)
> This is related to bug 756881 (maybe a dupe) and probably caused by bug
> 754608. Do all of these pages send the 'Cache-Control: no-store' header?

Yeah, same on twitter, distrowatch and imageshack

Cache-Control:no-cache, no-store, must-revalidate, pre-check=0, post-check=0

Thanks for your interest.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 756881
You need to log in before you can comment on or make changes to this bug.