Last Comment Bug 760803 - Address/Awesome bar: URL completion overrides selection from drop-down list
: Address/Awesome bar: URL completion overrides selection from drop-down list
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: x86_64 All
: -- normal with 1 vote (vote)
: ---
Assigned To: Marco Bonardo [::mak]
:
Mentors:
: 760833 760838 760843 (view as bug list)
Depends on:
Blocks: 720081
  Show dependency treegraph
 
Reported: 2012-06-02 06:28 PDT by B.J. Herbison
Modified: 2012-06-21 09:14 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments

Description B.J. Herbison 2012-06-02 06:28:13 PDT
Steps to reproduce:
* With the 2 June Nightly, create a new tab.
* Start typing in awesome bar. Choose characters such that URL completion occurs and a selection list appears.
* Click on a selection from the drop down list.
* Verify the URL from the selected item appears in the awesome bar.
* Press Enter.

Expected: Visit the selected URL, as shown in the awesome bar.

Actual: The URL from the URL completion step reappears in the awesome bar and that page is visited.

I see this issue on Ubuntu, also seen on Windows (<http://forums.mozillazine.org/viewtopic.php?p=12028013#p12028013>).
Comment 1 B.J. Herbison 2012-06-02 06:32:37 PDT
I just verified I get the same behavior with a new profile.

Workaround: Hit the space bar between selecting the URL and pressing Enter.
Comment 2 Alice0775 White 2012-06-02 06:48:52 PDT
Regression window:
Good:
http://hg.mozilla.org/mozilla-central/rev/7bf0125b26b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120601035703
Bad:
http://hg.mozilla.org/mozilla-central/rev/305cd10b57d2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120601055003
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7bf0125b26b5&tochange=305cd10b57d2

Suspected: bug Bug 720081
Comment 3 Alice0775 White 2012-06-02 08:52:00 PDT
Reproduced on today's Aurora too
http://hg.mozilla.org/releases/mozilla-aurora/rev/10b7f6c9be4f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120602 Firefox/14.0a2 ID:20120602042008
Comment 4 Alice0775 White 2012-06-02 10:58:28 PDT
*** Bug 760838 has been marked as a duplicate of this bug. ***
Comment 5 Alice0775 White 2012-06-02 11:02:50 PDT
*** Bug 760836 has been marked as a duplicate of this bug. ***
Comment 6 Marco Bonardo [::mak] 2012-06-02 11:20:46 PDT
Please do not back out bug 720081, We have a db version bump there. Will look into this soon
Comment 7 Alice0775 White 2012-06-02 11:24:39 PDT
*** Bug 760843 has been marked as a duplicate of this bug. ***
Comment 8 Will Budreau 2012-06-02 11:26:42 PDT
Alice0775 bug 760843 is different steps: type "yahoo" and press enter no longer takes uesr straight to web page.].  The user in question doesn't have any autocomplete that appears in dropplist when typing yahoo.
Comment 9 Alice0775 White 2012-06-02 11:30:59 PDT
(In reply to Will Budreau from comment #8)
> Alice0775 bug 760843 is different steps: type "yahoo" and press enter no
> longer takes uesr straight to web page.].  The user in question doesn't have
> any autocomplete that appears in dropplist when typing yahoo.

If You mean Bug 760836, Yes, it is intentional behavior.
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-02 12:28:50 PDT
We can back out the autocomplete controller changes only, right? That should fix this, so I think we should do that while we investigate further.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-02 12:29:09 PDT
(and then retrigger nightlies)
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-02 13:44:22 PDT
I tried to retrigger nightlies, but I'm not sure whether I succeeded.
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-06-02 13:46:59 PDT
Looks like the nightly builds are running now.
Comment 15 tablo13 2012-06-02 15:59:03 PDT
nope, not yet.
Comment 16 tablo13 2012-06-02 19:29:46 PDT
Aurora and Nightly builds are fixed now, completely resolved.
Comment 17 Marco Bonardo [::mak] 2012-06-03 01:55:35 PDT
*** Bug 760833 has been marked as a duplicate of this bug. ***
Comment 18 Virgil Dicu [:virgil] [QA] 2012-06-21 09:14:17 PDT
Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0

Verified in F14 beta 8 on Ubuntu 12.04, Mac OS 10.7 and Windows XP using steps from comment 0.

Note You need to log in before you can comment on or make changes to this bug.