Closed Bug 760805 Opened 10 years ago Closed 10 years ago

position:fixed and right/bottom alignment behave behave oddly

Categories

(Firefox for Android Graveyard :: General, defect)

15 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 758620

People

(Reporter: ben.kol, Assigned: cwiiis)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5

Steps to reproduce:

added an element to a page with "position:fixed" and "right:0" styling.
zoomed


Actual results:

the element behaved as if the viewport width doesn't change or as if it is left aligned, the element drifted outside the viewport to the right.


Expected results:

The element should have stayed positioned relative to the right edge of the screen.
The problem also occurs with bottom positioning.

Sample page I made: http://services.crossreader.net/mozilla-test/
I was seeing similar weirdness with postion:fixed and right:xx styled elements when I was investigating bug 757362.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
For the moment, this is expected behaviour - a solution is suggested in bug 607417.
This will be fixed with the work for bug 758620.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Depends on: 758620
Marking this as a duplicate of bug 758620.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758620
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.