If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Program Compatibility Assistant shown on Windows 7 when setting as default mail client

RESOLVED FIXED

Status

Thunderbird
OS Integration
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed, thunderbird15+ fixed, thunderbird-esr1013+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR

1. Take Win732/Win732 SP1IE8/Win7 32SP1IE9 machine.
2. Install Thunderbird beta 4: https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/13.0b4/win32/en-US/
3. Select “I think I will configure my account later” option in the Welcome to Thunderbird screen.
4. Select Ok in the System Integration window.

"Program Compatibility Assistant" is shown as per the attached dialog.
(Reporter)

Comment 1

5 years ago
Created attachment 629483 [details]
Program Compatibility Error
(Reporter)

Comment 2

5 years ago
So I think the issue here is potentially from previous installs - the certificate of helper.exe was for Mozilla Messaging, but on upgrade, although we've replaced the helper.exe with a correctly signed Mozilla Corporation certificate, there's something not quite right in the installation process.

I can't see any other way this could have got a reference to a Mozilla Messaging certificate in the current builds.
(Reporter)

Updated

5 years ago
Summary: Program Compatibility Assistant shown on Windows 8 when setting as default mail client → Program Compatibility Assistant shown on Windows 7 when setting as default mail client
"Program Compatibility Assistant shown on Windows 7 when setting as default mail client"

Ah, that's much more worrying, OK.
(Reporter)

Comment 4

5 years ago
This may have been caused by a regression in our build setup of bug 670034.

Main questions we have at the moment:

- How much does this affect fresh installs of Thunderbird?
- Are there any obvious effects of this bug other than the program compatibility assistant being displayed?
tracking-thunderbird13: ? → +
tracking-thunderbird14: ? → +
See Also: → bug 670034
(Reporter)

Comment 5

5 years ago
(In reply to Mark Banner (:standard8) from comment #4)
> This may have been caused by a regression in our build setup of bug 670034.
> 
> Main questions we have at the moment:
> 
> - How much does this affect fresh installs of Thunderbird?
> - Are there any obvious effects of this bug other than the program
> compatibility assistant being displayed?

Also, does this affect Thunderbird 12?
Well, I believe this caused our shortcut maintenance code to stop working if the user picked the Reinstall option (since the installer thinks it's running on Vista), though we haven't needed the code for some time now since our shortcut app id doesn't change... (see bug 692295).
The thing to check is the supportedOS in the manifest. If one is missing or the Windows 7 entry isn't found then Windows pops that dialog box up. See http://msdn.microsoft.com/en-us/library/aa374191.aspx (search for supportedOS).

You can get hold of the manifest with Resource Hacker <http://www.angusj.com/resourcehacker/>. Open uninstall/helper.exe in Resource Hacker, then navigate to 24/1/1033. Look for supportedOS in there.

Comment 8

5 years ago
I've just installed Thunderbird from link in #c0 and it didn't happen to me. Fresh install on brand new notebook on Windows 7, 64-bit though (the description says about 32-bit).

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120529 Thunderbird/13.0
(Reporter)

Comment 9

5 years ago
(In reply to Siddharth Agarwal [:sid0] (unavailable until late June) from comment #6)
> Well, I believe this caused our shortcut maintenance code to stop working if
> the user picked the Reinstall option (since the installer thinks it's
> running on Vista), though we haven't needed the code for some time now since
> our shortcut app id doesn't change... (see bug 692295).

If 6/2012 is the target date for that, then I'd be tempted to remove our use of it. Will try and get the helper.exe checked soon though.
After reading comment#0, comment#2, comment#8:

Is this happening only to TB users who:
1) are upgrading from previous Thunderbird
2) ...where previous Thunderbird was signed with MoMo key, not MoCo key?
(Reporter)

Comment 11

5 years ago
(In reply to John O'Duinn [:joduinn] from comment #10)
> After reading comment#0, comment#2, comment#8:
> 
> Is this happening only to TB users who:
> 1) are upgrading from previous Thunderbird
> 2) ...where previous Thunderbird was signed with MoMo key, not MoCo key?

Now I've re-read the dialog, and thought about it, I think the Mozilla Messaging may actually be coming from here:

http://mxr.mozilla.org/comm-central/source/other-licenses/branding/thunderbird/branding.nsi#43

Especially as the dialog says publisher, and not signed by.
For information, yesterday I have made a fresh install of Earlybird (so TB14, not 13) on a new PC (with win 7), and I had no problem like this.
(Reporter)

Comment 13

5 years ago
STR that I've been using:

1) Install Thunderbird, don't start it
2) Set Windows Live Mail as default client (in WLM, menu -> Options -> Mail -> Set default)
3) Start Thunderbird with a fresh profile, i.e. in the application directory

thunderbird.exe -createProfile temp
thunderbird.exe -P temp

4) Dismiss the account wizard/sign up form (whichever is shown)
5) Click OK on the system integration dialog

=> Within a couple of seconds, the dialog shown in attachment 629483 [details] appears. Click cancel on the dialog.

Alternate STRs:

1) With Thunderbird already installed
2) Set Windows Live Mail as default client (in WLM, menu -> Options -> Mail -> Set default)
3) In Thunderbird, go to Tools -> Options -> Advanced followed by Set Default Client
4) Click OK on the system integration dialog

=> Within a couple of seconds the dialog shown in attachment 629483 [details] appears. Click cancel on the dialog.
Keywords: qawanted, regressionwindow-wanted
(Reporter)

Comment 14

5 years ago
With the STR I've been able to reproduce on 10.0.5esr and 13.0 candidates, but not 12.0.1.
(Reporter)

Comment 15

5 years ago
My current assumption is that the manifest for helper.exe is missing this section:

   <compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
     <application>
       <supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}" />
     </application>
   </compatibility>

I've been trying to do this:

> mt.exe -inputresource:helper.exe;1 -out temp.manifest
*** insert section above just before closing </assembly> in temp.manifest ***
> mt.exe -NOLOGO -manifest temp.manifest -updateresource:helper.exe;1

However, when I've been doing that, the resultant helper.exe fails to load due to an issue with the CRC check.

In case its my Windows set up, I've pushed a patch to try server to attempt to use the same tools as the builders are using, although I'm not that confident:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=daced1482f5d

Ted/sid0/khuey, any suggestions?
Severity: normal → major
Created attachment 629719 [details]
screenshot

Try builds aren't signed.

When I do the following STRs :
Install the build
Launch the build
esc for creation of the account
Say yes to make Thunderbird default I get an exception
The installer you are trying to use is corrupted or incomplete this could be the result ... see screenshot
Yeah, updating the manifest updates the binary but not the CRC. (I didn't realize that at the time of suggesting that workaround.) I don't think that's avoidable unless we find a way to update the CRC as well.

Note that signing must take place *after* the manifest is updated, otherwise the signature would be invalid too.
I whipped up a quick updatecrc.exe, and tested with your commandlines from comment 15, and mt.exe appears to update the CRC properly. (Although the linker doesn't seem to generate a CRC at all for me initially.)

Source: http://pastebin.mozilla.org/1655210
(Reporter)

Comment 19

5 years ago
We fixed this in Thunderbird 13 and 10.0.5esr by upgrading the version of nsis that we were using to generate the builds (this had been accidentally downgraded in a build automation change over).

Bug 762218 is handling the roll-out of that version to all the appropriate windows slaves.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-thunderbird13: --- → fixed
status-thunderbird14: --- → fixed
status-thunderbird-esr10: --- → fixed
tracking-thunderbird-esr10: --- → 13+
Resolution: --- → FIXED
(Reporter)

Comment 20

5 years ago
Actually, I'm going to leave the bug open until we've fixed the builders as well.
Status: RESOLVED → REOPENED
status-thunderbird14: fixed → ---
tracking-thunderbird15: --- → +
Depends on: 762218
Resolution: FIXED → ---
(Reporter)

Comment 21

5 years ago
This was all fixed as of 13, and we've confirmed the fix through for the next releases.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-thunderbird14: --- → fixed
status-thunderbird15: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.