Occasional failure to get browser ID pop-up to appear when visiting myapps dashboard with a dirty profile

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Details

(Whiteboard: [blocking-aitc+])

(Reporter)

Description

7 years ago
On a dirty windows profile, both James and I experienced occasional failures to get the browser ID pop-up to come up on the myapps dashboard with a dirty profile on Windows. I can still consistently reproduce this behavior with my dirty profile I use (e.g. my profile I use for daily work) visiting the myapps dashboard anywhere. Anant mentioned a deletion of a webapps directory is required first, although I'm confused as to why this is required (it shouldn't require user modification of an underlying system). Error message seen in the console is below:


1338555311267    Services.Common.RESTRequest    WARN    Exception when calling user-supplied callback: m is null JS Stack trace: gotManifest@client.js:81 < @Webapps.jsm:330 < remoteInstall@client.js:80 < _putApps@manager.js:378 < _validateToken@manager.js:217 < _processQueue@manager.js:301 < @manager.js:58 < @manager.js:534 < _gotToken@manager.js:476 < @manager.js:465 < callCallback@tokenserverclient.js:176 < processTokenResponse@tokenserverclient.js:255 < onResponse@tokenserverclient.js:186 < onStopRequest@rest.js:433
(Reporter)

Comment 1

7 years ago
Note to self - Re-test this when AITC desktop lands in nightly.
(Reporter)

Comment 2

7 years ago
In doing my test pass right now, this definitely occurs on a different machine after using two distinct firefox profiles after installing and deleting apps overtime. Without this bug fixed, this makes testing an absolute pain, because it's not easy to change what browser ID account you are logged into in the dashboard. It also isn't really a good experience for someone wanting to manage apps across multiple accounts.

I'd really like this to be fixed especially for the testing side of things, as this would make my life easier if it was...
(Reporter)

Comment 3

7 years ago
I'm wondering if this is a mistake on my end during my testing where I'm already logged into marketplace from a previous session, open firefox, and go to myapps. Might want to double-check this though.
(Reporter)

Updated

6 years ago
Keywords: qawanted
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-aitc]
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-aitc] → [blocking-aitc+]
(Reporter)

Comment 4

6 years ago
I've confirmed on a vanilla OS X 10.7 machine that this issue definitely occurs even when not logged into marketplace. There are work-arounds to get around this bug sometimes though (usually involving refreshing the dashboard).
Keywords: qawanted
(Reporter)

Updated

6 years ago
Summary: Occasional failure to get browser ID pop-up to appear when visiting myapps dashboard with a dirty profile on Windows → Occasional failure to get browser ID pop-up to appear when visiting myapps dashboard with a dirty profile
OS: Windows 7 → All
Hardware: x86 → All
I'm unable to reproduce this. Are there particular circumstances under which we can force this to occur?
(Reporter)

Updated

6 years ago
Keywords: qawanted
(Reporter)

Updated

6 years ago
QA Contact: jsmith
(Reporter)

Comment 6

6 years ago
Tough to reproduce, but possible. The case I think I got this to work (still working on getting a consistent STR) was reusing an existing profile that I've previously logged into marketplace. Then, I closed firefox. Restarted it. When to marketplace, it says I'm logged out. When I go to myapps, no prompt comes up, because myapps thinks I'm already logged into the AITC server (as shown by the logs below). 

Not sure now if this is a bug or not, but from what I can tell, it looks like that closing firefox does not necessarily always log you out of the AITC server in all cases. Restarting firefox may keep you in the session you were logged in for the previous firefox session.

Also based on the fact that this is "hard" to reproduce, not sure if this should still block the release or not. Thoughts?

A log is below:

1341883013132	Service.AITC	INFO	Loading AitC
1341883013133	Service.AITC.Manager	INFO	Loading AitC manager module
1341883013133	Service.AITC.Storage.Queue	INFO	AitcQueue instance loading
1341883013133	Service.AITC.Storage.Queue	INFO	AitcQueue instance created
1341883013133	Service.AITC.Manager	INFO	AitC manager has finished loading
1341883013133	Service.AITC.Manager	INFO	Attempting to obtain assertion silently
1341883013698	Service.AITC.BrowserID	INFO	_getAssertionWithDomain Started
1341883013698	Service.AITC.BrowserID	INFO	_getAssertionWithEmail Started
1341883013864	Service.AITC.BrowserID	INFO	BrowserID.User.getAssertion succeeded
1341883013864	Service.AITC.Manager	INFO	gotSilentAssertion called
1341883013865	Service.AITC.Manager	INFO	Got assertion from BrowserID, creating token
1341883013865	Service.AITC.Manager	INFO	Obtaining token from https://stage-token.services.mozilla.com/1.0/aitc/1.0
1341883015154	Service.AITC	INFO	Dashboard was accessed [object Window]
1341883015229	Service.AITC.Manager	INFO	Attempting to obtain assertion silently
1341883015383	Service.AITC.BrowserID	INFO	_getAssertionWithDomain Started
1341883015383	Service.AITC.BrowserID	INFO	_getAssertionWithEmail Started
1341883015602	Service.AITC.BrowserID	INFO	BrowserID.User.getAssertion succeeded
1341883015602	Service.AITC.Manager	INFO	gotSilentAssertion called
1341883015603	Service.AITC.Manager	INFO	Got assertion from BrowserID, creating token
1341883015603	Service.AITC.Manager	INFO	Obtaining token from https://stage-token.services.mozilla.com/1.0/aitc/1.0
1341883015686	Service.AITC.Manager	INFO	Got token from server: {"id":"eyJleHBpcmVzIjogMTM0MTg4MzI2OC4xMTMyNDMxLCAic2FsdCI6ICJhNzU3NTAiLCAidWlkIjogODA2MTQ4NTUsICJzZXJ2aWNlX2VudHJ5IjogImh0dHBzOi8vc3RhZ2UtYWl0YzEuc2VydmljZXMubW96aWxsYS5jb20ifUOxfjevIgxNmqdW2hzYlgBNtvsd","key":"1VmqHLMZGOhyPtF36cMLMjUKqPQ=","endpoint":"https://stage-aitc1.services.mozilla.com/1.0/80614855","uid":80614855}
1341883015687	Service.AITC.Client	INFO	Client initialized with token endpoint: https://stage-aitc1.services.mozilla.com/1.0/80614855
1341883015878	Service.AITC.Manager	INFO	Got token from server: {"id":"eyJleHBpcmVzIjogMTM0MTg4MzI2OC4zMzExMjEsICJzYWx0IjogIjVjZTRmYyIsICJ1aWQiOiA4MDYxNDg1NSwgInNlcnZpY2VfZW50cnkiOiAiaHR0cHM6Ly9zdGFnZS1haXRjMS5zZXJ2aWNlcy5tb3ppbGxhLmNvbSJ9MEZRY8Kusfavqekmk5ZOpMpOnZk=","key":"Gx1s4OcA9kjGpRfOk72r7mp3JdU=","endpoint":"https://stage-aitc1.services.mozilla.com/1.0/80614855","uid":80614855}
1341883015878	Service.AITC.Client	INFO	Client initialized with token endpoint: https://stage-aitc1.services.mozilla.com/1.0/80614855
1341883015879	Service.AITC.Manager	INFO	Starting GET timer
1341883015879	Service.AITC.Manager	INFO	GET timer set, next attempt in 120000ms
1341883015883	Service.AITC.Manager	INFO	Attempting to getApps
1341883016166	Service.AITC.Client	INFO	getApps succeeded and got 0
1341883016166	Service.AITC.Manager	INFO	No apps found on remote server
1341883019880	Service.AITC	INFO	Dashboard closed or in background
1341883019880	Service.AITC.Manager	INFO	Starting GET timer
1341883019880	Service.AITC.Manager	INFO	GET timer set, next attempt in 7200000ms
1341883073242	Service.AITC	INFO	Dashboard was accessed [object Window]
1341883073242	Service.AITC.Manager	INFO	Starting GET timer
1341883073242	Service.AITC.Manager	INFO	GET timer set, next attempt in 120000ms
1341883073248	Service.AITC.Manager	INFO	Attempting to getApps
1341883074313	Service.AITC	INFO	Dashboard was accessed [object Window]
1341883074479	Service.AITC.Client	INFO	getApps succeeded and got 0
1341883074479	Service.AITC.Manager	INFO	No apps found on remote server
1341883076024	Service.AITC	INFO	Dashboard was accessed [object Window]
1341883091511	Service.AITC	INFO	Dashboard closed or in background
1341883091512	Service.AITC.Manager	INFO	Starting GET timer
1341883091512	Service.AITC.Manager	INFO	GET timer set, next attempt in 7200000ms
1341883094991	Service.AITC	INFO	Dashboard was accessed [object Window]
1341883094991	Service.AITC.Manager	INFO	Starting GET timer
1341883094992	Service.AITC.Manager	INFO	GET timer set, next attempt in 120000ms
1341883094996	Service.AITC.Manager	INFO	Attempting to getApps
1341883095075	Service.AITC.Client	INFO	getApps succeeded and got 0
1341883095075	Service.AITC.Manager	INFO	No apps found on remote server
1341883096185	Service.AITC	INFO	Dashboard was accessed [object Window]
Keywords: qawanted
Thanks for the details. I don't think this is a bug. If the login prompt doesn't appear it means you are logged in. I think we can do a better job of letting the user know whether they are logged into AITC or not, but the dashboard is going to revamped significantly again, so we'll do it then.

Although you're logged out of Marketplace, you're still logged into AITC because you're logged into BrowserID and we were able to determine what email you last used to login to Marketplace with. That's all we need to know, you don't necessarily have to be logged into Marketplace at the same time.

To verify this, try logging out of BrowserID from browserid.org before restarting and see if the popup appears when you visit the dashboard. (Logging out of BrowserID after the restart won't make this happen since we will obtain an assertion right away on startup).
(Reporter)

Comment 8

6 years ago
(In reply to Anant Narayanan [:anant] from comment #7)
> Thanks for the details. I don't think this is a bug. If the login prompt
> doesn't appear it means you are logged in. I think we can do a better job of
> letting the user know whether they are logged into AITC or not, but the
> dashboard is going to revamped significantly again, so we'll do it then.
> 
> Although you're logged out of Marketplace, you're still logged into AITC
> because you're logged into BrowserID and we were able to determine what
> email you last used to login to Marketplace with. That's all we need to
> know, you don't necessarily have to be logged into Marketplace at the same
> time.
> 
> To verify this, try logging out of BrowserID from browserid.org before
> restarting and see if the popup appears when you visit the dashboard.
> (Logging out of BrowserID after the restart won't make this happen since we
> will obtain an assertion right away on startup).

Tested and this aligns with what you've said above. Going to resolve this as invalid, as it appears this is expected behavior based on what you have described (and it makes sense).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.