Closed Bug 761004 Opened 12 years ago Closed 6 years ago

crash in mozilla::layers::CompositorParent::ResumeComposition

Categories

(Core :: Graphics: Layers, defect, P3)

ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- wontfix
firefox22 --- wontfix
firefox24 --- wontfix
firefox25 --- wontfix
firefox47 --- affected

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, Whiteboard: [native-crash][gfx-noted])

Crash Data

It first appeared in 15.0a1/20120602 and has been hit by one user. The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=73783bf75c4c&tochange=5199196b65ec
I think it's a regression from bug 759162.
It's probably related to bug 761003.

Signature 	mozilla::layers::CompositorParent::ResumeComposition More Reports Search
UUID	8292d761-29f4-4031-942a-86b932120603
Date Processed	2012-06-03 16:50:37
Uptime	32
Last Crash	34 seconds before submission
Install Age	7.3 minutes since version was first installed.
Install Time	2012-06-03 16:43:01
Product	FennecAndroid
Version	15.0a1
Build ID	20120603030523
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.35.14-cyanogenmod+ #1 PREEMPT Fri Jan 6 20:08:57 EST 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0x0
App Notes 	
AdapterVendorID: vision, AdapterDeviceID: HTC Vision.
AdapterDescription: 'Model: 'HTC Vision', Product: 'htc_vision', Manufacturer: 'HTC', Hardware: 'vision''.
HTC HTC Vision
htc_wwe/htc_vision/vision:2.3.3/GRI40/84109:user/release-keys
EMCheckCompatibility	False

Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::layers::CompositorParent::ResumeComposition 	gfx/layers/ipc/CompositorParent.cpp:143
1 	libxul.so 	mozilla::layers::CompositorParent::ResumeCompositionAndResize 	gfx/layers/ipc/CompositorParent.cpp:166
2 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple2<int, int> >::Run 	ipc/chromium/src/base/tuple.h:400
3 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
4 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
5 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
6 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
7 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
8 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
9 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
10 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:31
11 	libc.so 	libc.so@0x11e9a 	
12 	libc.so 	libc.so@0x11a76

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3ACompositorParent%3A%3AResumeComposition
Crash Signature: [@ mozilla::layers::CompositorParent::ResumeComposition] → [@ mozilla::layers::CompositorParent::ResumeComposition] [@ mozilla::layers::CompositorParent::ResumeComposition()]
Version: 15 Branch → Trunk
There's a crash in Nightly with a slightly different stack trace:
0 	libxul.so 	mozilla::layers::CompositorParent::ResumeComposition 	gfx/layers/ipc/CompositorParent.cpp:351
1 	libxul.so 	RunnableMethod<mozilla::ipc::AsyncChannel, void 	ipc/chromium/src/base/tuple.h:400
2 	libxul.so 	mozilla::layers::CompositorParent::SetEGLSurfaceSize 	gfx/layers/ipc/CompositorParent.cpp:381
3 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:334
4 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:342
5 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:442
6 	libmozglue.so 	arena_malloc 	memory/mozjemalloc/jemalloc.c:4159
7 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
8 	libxul.so 	base::CreatePlatformFile 	ipc/chromium/src/base/platform_file_posix.cc:66
9 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:216
10 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:209
11 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3ACompositorParent%3A%3AResumeComposition%28%29
Keywords: regression
Whiteboard: [native-crash] → [native-crash][startupcrash]
Whiteboard: [native-crash][startupcrash] → [native-crash]
This crash is still being reported, approximately 100 reports over the last week with Fennec 47.
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.