Last Comment Bug 761084 - JMenuBar not working in JApplet
: JMenuBar not working in JApplet
Status: RESOLVED DUPLICATE of bug 703007
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 12 Branch
: x86 Mac OS X
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 01:31 PDT by Simon Hagström
Modified: 2013-08-05 03:28 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Simon Hagström 2012-06-04 01:31:51 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I embedded an Applet with a JMenuBar in a HTML file.


Actual results:

Whenever I try to select an item in the second menu the first menu gets highlighted.

The issue is described here: http://www.dreamchain.com/jmenubar-not-working-for-japplet-in-firefox-on-mac/


Expected results:

The second menu should stay highlighted and I should be able to select an item from the second menu.
Comment 1 Andre Klapper 2012-06-04 02:18:04 PDT
Which browsers does it work with?
Comment 2 Simon Hagström 2012-06-04 02:23:26 PDT
Any other browser I have tried. E.g. Chrome 19, Safari 5.1.7.
Comment 3 hrejwan 2012-06-04 11:10:21 PDT
I would like to confirm this behavior on:

Mac OS X 10.7.4
FireFox 10.0.5 ESR
Java 1.6.0_31 

We observe this behavior using popup menus as well. If you bring up Java applet popup menu a try to scroll down the menu, the popup menu will be closed and the first Menu bar’s menu will be opened instead.
Comment 4 Nicholas Sherlock 2012-09-15 00:29:33 PDT
I am able to click menu items from the second and subsequent menus correctly with these setup:

Mac OS X 10.8.1
Firefox 15.0.1
Java Plug-in 10.7.0.10
JRE 1.7.0_07-b10 64-bit

However:

The menu items that the cursor points to are not highlighted with the blue rollover like the system menus are, the first item in the list stays highlighted instead. Presumably as a consequence, pop-out sub menus do not pop out unless clicked on.

If the mouse cursor ever leaves the popped up menu area, the first File menu is suddenly selected, just as described in this bug report. This behaviour is unlike the system menus and unlike JMenu on the same version of Java and Firefox on Windows XP.

Now, if you look at the behaviour of the same version of Java in Safari 6.0:

The menu items that the cursor points to are not highlighted, just like with Firefox! Pop-out sub menus do not pop out unless clicked on.

If the mouse cursor ever leaves the popped up menu area, the correct menu _stays open_. It remains open unless the mouse cursor leaves the applet area and returns to the applet, at which time the first File menu gets popped open.


So the Firefox bug seems to be that the mouse cursor leaving the area of a popped-up menu causes the first menu to be opened instead.
Comment 5 Nicholas Sherlock 2012-09-15 00:43:27 PDT
This bug does not occur when the applet uses th Nimbus Look&Feel: The mouse can leave the popped-up menu and the correct menu stays open. Menu items still do not highlight when rolled over, though.

The same issue does occur on the Metal L&F. So both the Mac Aqua and Metal L&F demonstrate this issue, Nimbus does not.
Comment 6 vze2k3sa 2013-07-31 15:55:31 PDT
(In reply to Nicholas Sherlock from comment #5)
> This bug does not occur when the applet uses th Nimbus Look&Feel: The mouse
> can leave the popped-up menu and the correct menu stays open. Menu items
> still do not highlight when rolled over, though.
> 
> The same issue does occur on the Metal L&F. So both the Mac Aqua and Metal
> L&F demonstrate this issue, Nimbus does not.

Fighting to get a duplicate bug fixed. (Bug 703007) Add you votes please !!!
Comment 7 Georg Fritzsche [:gfritzsche] 2013-08-05 03:28:24 PDT

*** This bug has been marked as a duplicate of bug 703007 ***

Note You need to log in before you can comment on or make changes to this bug.