Last Comment Bug 761089 - Missing Opus export in glmedias.dll in mingw builds
: Missing Opus export in glmedias.dll in mingw builds
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-04 01:51 PDT by Jacek Caban
Modified: 2012-06-05 05:56 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (609 bytes, patch)
2012-06-04 01:51 PDT, Jacek Caban
kinetik: review+
Details | Diff | Review

Description Jacek Caban 2012-06-04 01:51:12 PDT
Created attachment 629724 [details] [diff] [review]
fix v1.0

Bug 759612 introduced using more symbold from Opus that are not explicitly exported by symbold.def. It works on MSVC because __declspec(dllexport) is used there. While __declspec(dllexport) could work on mingw (it's a matter of changing Opus headers a bit), I think using symbols.def is a better idea.
Comment 1 Matthew Gregan [:kinetik] 2012-06-04 02:15:37 PDT
Comment on attachment 629724 [details] [diff] [review]
fix v1.0

Thanks!
Comment 2 Jacek Caban 2012-06-04 04:03:46 PDT
Thanks for the quick review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/b6067aa77360
Comment 3 Geoff Lankow (:darktrojan) 2012-06-05 05:56:30 PDT
https://hg.mozilla.org/mozilla-central/rev/b6067aa77360

Note You need to log in before you can comment on or make changes to this bug.