Closed Bug 761131 Opened 9 years ago Closed 9 years ago

java.lang.NullPointerException: at org.mozilla.gecko.BrowserToolbar.from(BrowserToolbar.java)

Categories

(Firefox for Android Graveyard :: General, defect)

15 Branch
ARM
Android
defect
Not set
blocker

Tracking

(firefox15 verified)

VERIFIED FIXED
Firefox 15
Tracking Status
firefox15 --- verified

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

It first appeared in 15.0a1/20120604 and has been hit by 5 users so far. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d0ebcaa7efb5&tochange=dd6ec482a85d
I think it's a regression from bug 750707.

java.lang.NullPointerException
	at org.mozilla.gecko.BrowserToolbar.from(BrowserToolbar.java:168)
	at org.mozilla.gecko.GeckoApp.refreshActionBar(GeckoApp.java:1747)
	at org.mozilla.gecko.GeckoApp.onConfigurationChanged(GeckoApp.java:2353)
	at android.app.ActivityThread.performConfigurationChanged(ActivityThread.java:3461)
	at android.app.ActivityThread.handleConfigurationChanged(ActivityThread.java:3585)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1220)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.BrowserToolbar.from%28BrowserToolbar.java%29
Regression from bug 750707.
Blocks: 750707
STR:

i) Rotate device


D/AndroidRuntime( 1934): Shutting down VM
W/dalvikvm( 1934): threadid=1: thread exiting with uncaught exception (group=0x40a5a1f8)
E/GeckoAppShell( 1934): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoAppShell( 1934): java.lang.NullPointerException
E/GeckoAppShell( 1934): 	at org.mozilla.gecko.BrowserToolbar.from(BrowserToolbar.java:168)
E/GeckoAppShell( 1934): 	at org.mozilla.gecko.GeckoApp.refreshActionBar(GeckoApp.java:1747)
STR: attempt to launch Fennec (Galaxy Tablet 10.1 on Android 3.1)

E/GeckoAppShell(19377): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec_morbo/org.mozilla.fennec_morbo.App}: java.lang.NullPointerException
E/GeckoAppShell(19377): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1818)
E/GeckoAppShell(19377): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1834)
E/GeckoAppShell(19377): 	at android.app.ActivityThread.access$500(ActivityThread.java:122)
E/GeckoAppShell(19377): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1027)
E/GeckoAppShell(19377): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/GeckoAppShell(19377): 	at android.os.Looper.loop(Looper.java:132)
E/GeckoAppShell(19377): 	at android.app.ActivityThread.main(ActivityThread.java:4126)
E/GeckoAppShell(19377): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoAppShell(19377): 	at java.lang.reflect.Method.invoke(Method.java:491)
E/GeckoAppShell(19377): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:844)
E/GeckoAppShell(19377): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:602)
E/GeckoAppShell(19377): 	at dalvik.system.NativeStart.main(Native Method)
E/GeckoAppShell(19377): Caused by: java.lang.NullPointerException
E/GeckoAppShell(19377): 	at org.mozilla.gecko.BrowserToolbar.from(BrowserToolbar.java:168)
E/GeckoAppShell(19377): 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:1795)
E/GeckoAppShell(19377): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1050)
E/GeckoAppShell(19377): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1782)
Severity: critical → blocker
Attachment #629765 - Flags: review?(mark.finkle) → review+
also pushed to m-c since this is a bad crash:
https://hg.mozilla.org/mozilla-central/rev/b4a1b0485188
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Duplicate of this bug: 761505
Verified Fixed (Nightly 06/05)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.