Use the same preferences for enabling and configuring the remote debugging server across products

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: past, Assigned: past)

Tracking

Trunk
Firefox 16
Points:
---

Firefox Tracking Flags

(firefox15 fixed)

Details

Attachments

(3 attachments)

Currently we are using different preferences to enable the remote debugging server across desktop Firefox, Firefox for Android and B2G, and to configure the port number:

- Desktop: devtools.debugger.remote-enabled, devtools.debugger.remote-port
- B2G: devtools.debugger.enabled, devtools.debugger.port
- Android: remote-debugger.enabled, remote-debugger.port

This has not been a big deal so far, but since we are going to be providing users with docs about enabling remote debugging soon, I think it's time we fix this discrepancy. After bug 758696, the check for devtools.debugger.remote-enabled is done in two places:
1) in the desktop UI, to decide whether the 'Remote Debugger' menu option should be displayed
2) in the server listener, to decide whether it should open a socket for incoming connections

The latter is done in toolkit/ so the respective pref must move there as well, in order to be reachable from other products as well.

In order to harmonize our code, I propose we use the same preferences found in desktop Firefox, in all of our products.
Created attachment 629833 [details] [diff] [review]
Desktop patch

Nice and simple.
Attachment #629833 - Flags: review?(rcampbell)
Created attachment 629834 [details] [diff] [review]
Fennec patch

Without this patch I need to manually set devtools.debugger.remote-enabled in about:config to get a working debugging connection.
Attachment #629834 - Flags: review?(mark.finkle)
Created attachment 629835 [details] [diff] [review]
B2G patch

Same as Fennec, I need to set devtools.debugger.remote-enabled to enable remote debugging without this patch.
Attachment #629835 - Flags: review?(21)
Attachment #629835 - Flags: review?(21) → review+
Attachment #629834 - Flags: review?(mark.finkle) → review+
Comment on attachment 629833 [details] [diff] [review]
Desktop patch

Actually, since this is not devtools code and robcee is on PTO, I might as well ask Mossop for a review.
Attachment #629833 - Flags: review?(rcampbell) → review?(dtownsend+bugmail)
Blocks: 762403
Attachment #629833 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/integration/fx-team/rev/877beffa7465
https://hg.mozilla.org/integration/fx-team/rev/6885795fc0b6
https://hg.mozilla.org/integration/fx-team/rev/c3616d652386
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/877beffa7465
https://hg.mozilla.org/mozilla-central/rev/6885795fc0b6
https://hg.mozilla.org/mozilla-central/rev/c3616d652386
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 16
do we need all three of these patches on aurora?
tracking-firefox15: --- → ?
Comment on attachment 629833 [details] [diff] [review]
Desktop patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: different platforms will have different configuration options.
Testing completed (on m-c, etc.): on m-c.
Risk to taking this patch (and alternatives if risky): low risk, pref changes only.
String or UUID changes made by this patch:
Pref changes to firefox.js:

-pref("devtools.debugger.remote-enabled", false);
 pref("devtools.debugger.remote-host", "localhost");
-pref("devtools.debugger.remote-port", 6000);

Pref changes to all.js:

+// Disable remote debugging connections
+pref("devtools.debugger.remote-enabled", false);
+pref("devtools.debugger.remote-port", 6000);
Attachment #629833 - Flags: approval-mozilla-aurora?

Comment 9

5 years ago
Comment on attachment 629833 [details] [diff] [review]
Desktop patch

[Triage Comment]
Low risk pref change early in the cycle - approved for Aurora 15.
Attachment #629833 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Rob Campbell [:rc] (:robcee) from comment #7)
> do we need all three of these patches on aurora?

I'm not exactly sure what the releng process for fennec and b2g is, but not getting them all in could create logistical issues down the road for us.
https://hg.mozilla.org/releases/mozilla-aurora/rev/6a51d098fc1f
https://hg.mozilla.org/releases/mozilla-aurora/rev/81ad66ec9297
https://hg.mozilla.org/releases/mozilla-aurora/rev/064efda12a0c
status-firefox15: --- → fixed
tracking-firefox15: ? → ---
You need to log in before you can comment on or make changes to this bug.