Gif crashes Mozilla

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
ImageLib
P1
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Gilles Durys, Assigned: saari (gone))

Tracking

({crash})

Trunk
mozilla0.9.1
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [imglib], URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
2001041508 trunk win98

Load http://www.uri.sakura.ne.jp/~anc/images/space.gif
-> Page fault in imglib32.dll

Talkback ID soon
(Reporter)

Updated

17 years ago
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 1

17 years ago
Small typo : page fault in imglib2.dll

TB29143489H

Comment 2

17 years ago
Dup of 74423?

Comment 3

17 years ago
Created attachment 30961 [details]
Error reported from an image viewer

Comment 4

17 years ago
I think the handling of an corrupted image (whether it's an JPG of GIF or other 
formats should get more robust.  Displaying a black block will give the user 
less frustration than just crashing.

Comment 5

17 years ago
jpeg and png have pretty solid error handling.  i'll look into this

Comment 6

17 years ago
i've added code to avoid the actual crash.. i'll fire assertions in the places 
where it would previouly crash.  handing over to saari to fix the conditions in 
the gif decoder that are causing it to (now) hit the assertions.
Assignee: pavlov → saari

Comment 7

17 years ago
*** Bug 57314 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
changing status to [imglib]
Whiteboard: [imglib]

Comment 9

17 years ago
*** Bug 75243 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 75284 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
*** Bug 74535 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 12

17 years ago
still crashes on Linux and Mac using today's bits.  
Priority: -- → P1
Summary: http://www.uri.sakura.ne.jp/~anc/images/space.gif crashes Mozilla → Gif crashes Mozilla
(Reporter)

Comment 13

17 years ago
Crashed too on 2001050104 win98
Talkback TB29877499K
(Assignee)

Comment 14

17 years ago
Created attachment 32954 [details] [diff] [review]
Patch to fix crash
(Assignee)

Comment 15

17 years ago
r=, sr= needed
(Assignee)

Comment 16

17 years ago
Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
*** Bug 57314 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Can't seem to get to image, verifying patch checked into lxr.mozilla.org
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.