Add in product and related models.

RESOLVED FIXED in 2012-06-14

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: andy+bugzilla, Assigned: wraithan)

Tracking

2012-06-14
x86
Mac OS X
Points:
---

Details

(Reporter)

Description

7 years ago
We'll need a product model to associate each transaction with. It will have a primary key and a uuid and that's about it. We'll store the paypal information in its own table (so each product can be associated with one or more payment providers).

There will be a product paypal model that contains all the paypal specific stuff for it. At this point it will be the: paypal_id, permissions_token and the supported currencies (this is currently a JSON field, but could be broken out into another table, if we feel so inclined). See apps/market/models.py for more info.
Assignee: nobody → xwraithanx
(Reporter)

Updated

7 years ago
Target Milestone: 2012-06-07 → 2012-06-14
(Reporter)

Comment 1

7 years ago
How far are you into this, would you mind if I take?
(Reporter)

Updated

7 years ago
Duplicate of this bug: 763101
(Reporter)

Comment 3

7 years ago
I added in seller models, sorry if I stepped on work you've done.
(Reporter)

Comment 4

7 years ago
Done
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.