Custom menu should scroll to top whenever it is shown

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 16
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 verified, firefox16 verified, firefox17 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Custom menu should scroll to top whenever it is shown. Currently only the visibility is changed for the menu.
(Assignee)

Updated

6 years ago
Assignee: nobody → sriram
OS: Mac OS X → Android
Hardware: x86 → ARM
(Assignee)

Comment 1

6 years ago
Created attachment 629872 [details] [diff] [review]
Patch

This patch makes sure that the custom menu scrolls to top, whenever it is opened.
openOptionsMenu() gets called for non-h/w menu button devices. onMenuOpened() gets called for h/w menu button devices.
Attachment #629872 - Flags: review?(mark.finkle)
Comment on attachment 629872 [details] [diff] [review]
Patch

ask for aurora approval too
Attachment #629872 - Flags: review?(mark.finkle) → review+

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e7f9c105f6a2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(Assignee)

Comment 5

6 years ago
Comment on attachment 629872 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: Custom menu will stay at the same position where it was left earlier. This is different from stock android's behavior.
Testing completed (on m-c, etc.): 06/06
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: -
Attachment #629872 - Flags: approval-mozilla-aurora?
Comment on attachment 629872 [details] [diff] [review]
Patch

[Triage Comment]
No risk, go for it.
Attachment #629872 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

6 years ago
status-firefox15: --- → fixed

Updated

6 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: --- → verified
status-firefox17: --- → verified
You need to log in before you can comment on or make changes to this bug.