Google maps causes X to crash on Ubuntu 12.04

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: mreid, Unassigned)

Tracking

({crash})

Trunk
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Opening http://maps.google.ca in Nightly causes X to crash in Ubuntu 12.04 on a Lenovo x220.

Steps to reproduce:
- Start Firefox
- Go to google maps (link above)

Actual results:
Desktop environment hangs.  The mouse cursor is still alive, but nothing else responds.  Sometimes the system semi-recovers and prompts to submit a crash report to Ubuntu.

Expected results:
Should let me use google maps.

Other info:
App Basics:
Name:       Firefox
Version:    15.0a1
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1

Graphics:
Adapter Description:     Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Mobile
Vendor ID:               Tungsten Graphics, Inc
Device ID:               Mesa DRI Intel(R) Sandybridge Mobile
Driver Version:          3.0 Mesa 8.0.2
WebGL Renderer:          Tungsten Graphics, Inc -- Mesa DRI Intel(R) Sandybridge Mobile  -- 3.0 Mesa 8.0.2
GPU Accelerated Windows: 0
AzureBackend:            skia


There is an error in the Xorg.0.log file starting with
[    90.443] [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
[    90.443] 
Backtrace:
[    90.444] 0: /usr/bin/X (xorg_backtrace+0x26) [0x7f51c2f41866]
[    90.444] 1: /usr/bin/X (mieqEnqueue+0x263) [0x7f51c2f21f43]
[    90.444] 2: /usr/bin/X (0x7f51c2db9000+0x62934) [0x7f51c2e1b934]
[    90.444] 3: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f51bd085000+0x5d88) [0x7f51bd08ad88]
[    90.444] 4: /usr/bin/X (0x7f51c2db9000+0x8ae07) [0x7f51c2e43e07]
[    90.444] 5: /usr/bin/X (0x7f51c2db9000+0xb0d4a) [0x7f51c2e69d4a]
[    90.444] 6: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f51c20df000+0xfcb0) [0x7f51c20eecb0]
[    90.444] 7: /lib/x86_64-linux-gnu/libc.so.6 (ioctl+0x7) [0x7f51c103dd27]
[    90.444] 8: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmIoctl+0x28) [0x7f51bf5d01a8]
[    90.444] 9: /usr/lib/x86_64-linux-gnu/libdrm_intel.so.1 (0x7f51bef59000+0x58c6) [0x7f51bef5e8c6]
[    90.444] 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f51bf176000+0xbece) [0x7f51bf181ece]
[    90.444] 11: /usr/bin/X (0x7f51c2db9000+0xc382a) [0x7f51c2e7c82a]
[    90.445] 12: /usr/bin/X (0x7f51c2db9000+0xce1eb) [0x7f51c2e871eb]
[    90.445] 13: /usr/bin/X (0x7f51c2db9000+0xccd8c) [0x7f51c2e85d8c]
[    90.445] 14: /usr/bin/X (miPointerUpdateSprite+0x29d) [0x7f51c2f2c92d]
[    90.445] 15: /usr/bin/X (0x7f51c2db9000+0x173c1d) [0x7f51c2f2cc1d]
[    90.445] 16: /usr/bin/X (0x7f51c2db9000+0xdba29) [0x7f51c2e94a29]
[    90.445] 17: /usr/bin/X (0x7f51c2db9000+0x1119ba) [0x7f51c2eca9ba]
[    90.445] 18: /usr/bin/X (0x7f51c2db9000+0x55fa9) [0x7f51c2e0efa9]
[    90.445] 19: /usr/bin/X (0x7f51c2db9000+0x592f5) [0x7f51c2e122f5]
[    90.445] 20: /usr/bin/X (0x7f51c2db9000+0x11ed20) [0x7f51c2ed7d20]
[    90.445] 21: /usr/bin/X (0x7f51c2db9000+0x14256a) [0x7f51c2efb56a]
[    90.445] 22: /usr/bin/X (mieqProcessDeviceEvent+0x204) [0x7f51c2f223b4]
[    90.445] 23: /usr/bin/X (mieqProcessInputEvents+0x84) [0x7f51c2f22444]
[    90.445] 24: /usr/bin/X (ProcessInputEvents+0x9) [0x7f51c2e43e89]
[    90.445] 25: /usr/bin/X (0x7f51c2db9000+0x4e4e3) [0x7f51c2e074e3]
[    90.445] 26: /usr/bin/X (0x7f51c2db9000+0x3d6aa) [0x7f51c2df66aa]
[    90.445] 27: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7f51c0f7476d]
[    90.445] 28: /usr/bin/X (0x7f51c2db9000+0x3d99d) [0x7f51c2df699d]
[    90.445] [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
[    90.445] [mi] mieq is *NOT* the cause.  It is a victim.
[    91.771] [mi] EQ overflow continuing.  100 events have been dropped.

Updated

6 years ago
Severity: normal → critical
Component: General → Graphics
Keywords: crash
Product: Firefox → Core
QA Contact: general → thebes
Version: 15 Branch → Trunk
(Reporter)

Comment 1

4 years ago
This crash doesn't happen anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.