Last Comment Bug 761256 - Disable Mac a11y in Aurora 15
: Disable Mac a11y in Aurora 15
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 15 Branch
: x86_64 Linux
-- normal (vote)
: mozilla16
Assigned To: Hubert Figuiere [:hub]
:
: alexander :surkov
Mentors:
Depends on:
Blocks: 759236 761574
  Show dependency treegraph
 
Reported: 2012-06-04 11:47 PDT by Hubert Figuiere [:hub]
Modified: 2012-06-05 10:43 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Disable a11y on Mac for Aurora. r= a= (1.51 KB, patch)
2012-06-04 11:57 PDT, Hubert Figuiere [:hub]
tbsaunde+mozbugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Hubert Figuiere [:hub] 2012-06-04 11:47:22 PDT
Disable Mac a11y in Aurora 15 (soon uplifted)

Disable the mochitest a11y on Mac as well.

Leave it in Nightly.
Comment 1 User image Hubert Figuiere [:hub] 2012-06-04 11:57:11 PDT
Created attachment 629868 [details] [diff] [review]
Disable a11y on Mac for Aurora. r= a=
Comment 2 User image Hubert Figuiere [:hub] 2012-06-04 12:27:55 PDT
Comment on attachment 629868 [details] [diff] [review]
Disable a11y on Mac for Aurora. r= a=

Review of attachment 629868 [details] [diff] [review]:
-----------------------------------------------------------------

Uplift is too soon. Requesting Aurora approval. This is a straight backout of bug 733513 and we want it in ASAP as Mac a11y seems to have had far too many side effects.
Comment 3 User image Hubert Figuiere [:hub] 2012-06-04 12:29:03 PDT
Aurora 15 I mean.
Comment 4 User image David Bolter [:davidb] 2012-06-04 13:04:20 PDT
I think we need this in nightly as well until bug 759736 is ready.
Comment 5 User image David Bolter [:davidb] 2012-06-04 13:07:31 PDT
Related mailing list discussion: http://bit.ly/Li5rPP
Comment 6 User image Hubert Figuiere [:hub] 2012-06-04 13:30:48 PDT
Disabling in 16 until we get the bug 759736 fixed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/195d06e53895
Comment 7 User image Alex Keybl [:akeybl] 2012-06-04 13:38:57 PDT
If I'm understanding what disabling a11y Mac support would mean, I don't think think we should just go and disable it on Aurora 15. For now, Aurora updates are disabled until we stabilize updates (see bug 761189). I think we should instead wait to see what happens in bug 759236 before taking drastic action.

Basically, we wouldn't ship with a11y disabled, so this bug is moot.
Comment 8 User image Hubert Figuiere [:hub] 2012-06-04 13:40:36 PDT
a11y was disabled on Mac in FF 14. It was enable for 15, but it seems to cause more issues. Disabling it is not a regression.
Comment 9 User image Trevor Saunders (:tbsaunde) 2012-06-04 13:51:42 PDT
(In reply to Alex Keybl [:akeybl] from comment #7)
> If I'm understanding what disabling a11y Mac support would mean, I don't
> think think we should just go and disable it on Aurora 15. For now, Aurora

we said when we turned a11y on just after branching 14 that we expected issues to arise and might well disable a11y on mac before release, so this isn't really just on a wim

> updates are disabled until we stabilize updates (see bug 761189). I think we
> should instead wait to see what happens in bug 759236 before taking drastic

I'm not sure how much we can investigate there, we know roughly what the problem is, but its not easily solved.
Comment 10 User image Alex Keybl [:akeybl] 2012-06-04 14:11:42 PDT
(In reply to Trevor Saunders (:tbsaunde) from comment #9)
> (In reply to Alex Keybl [:akeybl] from comment #7)
> > If I'm understanding what disabling a11y Mac support would mean, I don't
> > think think we should just go and disable it on Aurora 15. For now, Aurora
> 
> we said when we turned a11y on just after branching 14 that we expected
> issues to arise and might well disable a11y on mac before release, so this
> isn't really just on a wim
> 
> > updates are disabled until we stabilize updates (see bug 761189). I think we
> > should instead wait to see what happens in bug 759236 before taking drastic
> 
> I'm not sure how much we can investigate there, we know roughly what the
> problem is, but its not easily solved.

So there would be no regression for a user going from FF14 to FF15 at release if left disabled? I just want to verify that before approving.
Comment 11 User image Hubert Figuiere [:hub] 2012-06-04 14:17:59 PDT
No regression because a11y for Mac isn't enabled in FF14.
Comment 12 User image Alex Keybl [:akeybl] 2012-06-04 15:52:42 PDT
Comment on attachment 629868 [details] [diff] [review]
Disable a11y on Mac for Aurora. r= a=

[Triage Comment]
Approved for Aurora 15.
Comment 13 User image Hubert Figuiere [:hub] 2012-06-04 17:40:46 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/b765828410ff
Comment 14 User image alexander :surkov 2012-06-04 19:39:19 PDT
Hub, fixed?
Comment 15 User image Hubert Figuiere [:hub] 2012-06-04 19:46:38 PDT
(In reply to alexander :surkov from comment #14)
> Hub, fixed?

when it is merged to m-c.
Comment 16 User image Rob Campbell [:rc] (:robcee) 2012-06-05 06:00:21 PDT
Are we going to disable on Nightly as well?
Comment 17 User image Geoff Lankow (:darktrojan) 2012-06-05 06:16:34 PDT
https://hg.mozilla.org/mozilla-central/rev/195d06e53895
Comment 18 User image Marco Zehe (:MarcoZ) 2012-06-05 06:18:22 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #16)
> Are we going to disable on Nightly as well?

Temporarily yes, and then whitelist for VoiceOver, see bug 759736.

Also, if you need a11y enabled, there's a script in m.d.platform which you probably have seen.
Comment 19 User image Hubert Figuiere [:hub] 2012-06-05 10:43:52 PDT
(In reply to Rob Campbell [:rc] (:robcee) from comment #16)
> Are we going to disable on Nightly as well?

see comment 6

Note You need to log in before you can comment on or make changes to this bug.