New messages icon not showing up on Inbox

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: scottputterman, Assigned: Bienvenu)

Tracking

({regression})

Trunk
mozilla0.9
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using 2001041508 on Win 2000 (though I noticed this on builds from 4/13)

I see this on my IMAP account

1. Send yourself a mail
2. Wait for biff to go off
3. New message arrives in Inbox
4. Notice that the Inbox has no new message icon showing.

Filtered folders work fine, but the Inbox does not.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, regression
Priority: -- → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
(Reporter)

Comment 1

17 years ago
It turns out that new messages aren't getting the "New" status which probably 
explains why the folder icon doesn't change.
(Assignee)

Comment 2

17 years ago
I probably broke this somehow - I'll look at it.
Assignee: racham → bienvenu
(Assignee)

Comment 3

17 years ago
Created attachment 30996 [details] [diff] [review]
proposed fix
(Assignee)

Comment 4

17 years ago
cc'ing seth for sr. comments in patch. The semantics of AddNewHdrToDB are that
the caller sets the new flag on the msg hdr and add AddNewHdrToDB will reflect
that into the new set, but I broke that when I made nsMsgHdr::GetStatusFlags
check the new set. Actually, I just want to call GetRawFlags instead of GetFlags
- I'll attach a new patch.
(Assignee)

Comment 5

17 years ago
Created attachment 30998 [details] [diff] [review]
more succinct change
sr=sspitzer

Updated

17 years ago
QA Contact: esther → sheelar
(Assignee)

Comment 7

17 years ago
can I get an r= from bhuvan or gayatri so I can check this in before tomorrow's
build? thanks!
r=sspitzer, perhaps mscott can give you a super review instead.
(Assignee)

Comment 9

17 years ago
*** Bug 76280 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
marking verified,
2001041906-win98
2001041908-mac
2001041908-linux
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.