Last Comment Bug 761304 - mailnews/addrbook/test/unit/test_nsIAbCard.js has weak tests due to divergence of nsIAbCard between Thunderbird and SeaMonkey
: mailnews/addrbook/test/unit/test_nsIAbCard.js has weak tests due to divergenc...
Status: REOPENED
:
Product: Thunderbird
Classification: Client Software
Component: Address Book (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 16.0
Assigned To: Mike Conley (:mconley) - (Needinfo me!)
:
Mentors:
Depends on:
Blocks: 759328
  Show dependency treegraph
 
Reported: 2012-06-04 13:38 PDT by Florian Quèze [:florian] [:flo]
Modified: 2012-06-05 06:40 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
WIP (11.17 KB, patch)
2012-06-04 13:45 PDT, Florian Quèze [:florian] [:flo]
no flags Details | Diff | Splinter Review
Wallpaper patch v1 (16.90 KB, patch)
2012-06-04 14:27 PDT, Mike Conley (:mconley) - (Needinfo me!)
florian: review+
iann_bugzilla: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] 2012-06-04 13:38:20 PDT
The test at mailnews/addrbook/test/unit/test_nsIAbCard.js is broken since I landed bug 759238.

The cause is obviously at http://mxr.mozilla.org/comm-central/source/mailnews/addrbook/test/unit/test_nsIAbCard.js#45 
There's an hard coded XML result of the conversion of an address book card containing an AIM screen name.
Comment 1 Mike Conley (:mconley) - (Needinfo me!) 2012-06-04 13:39:17 PDT
Investigating...
Comment 2 Florian Quèze [:florian] [:flo] 2012-06-04 13:45:30 PDT
Created attachment 629910 [details] [diff] [review]
WIP

This make the test pass for Thunderbird, but would break the same test for SeaMonkey, as the C++ code contains ifdefs.
Comment 3 Mike Conley (:mconley) - (Needinfo me!) 2012-06-04 14:27:24 PDT
Created attachment 629929 [details] [diff] [review]
Wallpaper patch v1

This patch wallpaper over the failure by ensuring that the XML output for translateTo("xml") and translateTo("base64xml") match our expectations for Thunderbird OR SeaMonkey.

We're doing it this way because it's hard in XPCShell tests to determine which app we're in, and we're not able to do any preprocessing.

Hopefully we'll come up with a more graceful solution that doesn't weaken our tests after this lands, but the priority is to have a non-busted tree.

Ian: I don't have a SeaMonkey build handy. Do the nsIAbCard tests pass for you with this patch?
Comment 4 Florian Quèze [:florian] [:flo] 2012-06-04 15:04:41 PDT
Comment on attachment 629929 [details] [diff] [review]
Wallpaper patch v1

This is OK with me. Thanks for taking care of this!
Comment 5 Ian Neal 2012-06-04 16:37:09 PDT
Comment on attachment 629929 [details] [diff] [review]
Wallpaper patch v1

Test works both with and without the patch for SM (which is what is expected), so r=me
Comment 6 Mike Conley (:mconley) - (Needinfo me!) 2012-06-04 20:40:44 PDT
Thanks for the reviews - committed to comm-central as https://hg.mozilla.org/comm-central/rev/51f29333aafd.

Waiting for comm-aurora to open before I push there.
Comment 7 Mark Banner (:standard8) (afk until 26th July) 2012-06-05 04:14:55 PDT
Comment on attachment 629929 [details] [diff] [review]
Wallpaper patch v1

[Triage Comment]
a=me for bustage fix.
Comment 8 Mark Banner (:standard8) (afk until 26th July) 2012-06-05 04:19:25 PDT
Checked in: https://hg.mozilla.org/releases/comm-aurora/rev/9dcedc936a8e
Comment 9 Mike Conley (:mconley) - (Needinfo me!) 2012-06-05 06:39:54 PDT
Not sure why I marked this RESOLVED FIXED, since the comments in my patch mention that a more thorough fix will come from this bug.

Note You need to log in before you can comment on or make changes to this bug.