Status

()

Core
Layout
RESOLVED DUPLICATE of bug 101368
17 years ago
16 years ago

People

(Reporter: Ronald Clifford Buckman, Assigned: Marc Attinasi)

Tracking

({compat, testcase})

Trunk
mozilla1.2alpha
x86
Windows 98
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20010131
Netscape6/6.01
BuildID:    2001041508

The UL in the attached page displays off screen, even though the width of the
previous two side by side DIVs combined is 100% and there is a clear:both style
attribute in a HR. The attachment is a corrected version of
http://www.w3.org/WAI/css-layout

Reproducible: Always
Steps to Reproduce:
1.View attached page.

Actual Results:  UL is too far to the right, and the user has to scroll over to
see it.

Expected Results:  The UL should be below the other two DIVs

This page displays as it should in Netscape 4.08, IE 5.5 and Opera 5.10.  I used
Netscape 6 to fill this form because of bug 75695 (submit buttons not working).
(Reporter)

Comment 1

17 years ago
Created attachment 30965 [details]
This HTML attachment demonstrates bug 76132.
Your testcase triggers quirks mode.

Works if you change the doctype to
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
  "http://www.w3.org/TR/html4/loose.dtd">

Note:
1. double quotes instead of single quotes
2. Version 4.01 instead of 4.0
3. URI of DTD included

Don't know if (1) and (2) are bugs. (3) is a feature, not a bug.
Whatsoever, this should work in quirks mode too, I think.

Comment 3

17 years ago
If you change <HR style="clear:both"> to <HR style="display:block; clear:both">
then it works. Could be related to bug 38370.

Comment 4

17 years ago
This is a dupe of bug 35666 ([FLOAT] problem with bullets).

If anyones else agrees (ron?) I will mark it.
Summary: UL displays off screen → [dupe]UL displays off screen
This is not a dupe of bug 35666. AIUI, when 35666 is fixed, ULs will use
available space below floats, but still start at their upper right corner.
That might be correct behavior even if the float has width=100%. The problem
here is that "clear" does not work.

I'm confirming this now. Component is Layout, I think.
Another related bug is bug 33530.
Assignee: pierre → karnaze
Status: UNCONFIRMED → NEW
Component: Style System → Layout
Ever confirmed: true
QA Contact: ian → petersen
Summary: [dupe]UL displays off screen → UL displays off screen

Comment 6

17 years ago
Reassigning to attinasi.
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla1.0
Keywords: compat, testcase

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2

Comment 7

16 years ago
The problem is that <hr style="clear:both"> have no effect in quirk mode.
Testcase looks great in strict mode ;-)

*** This bug has been marked as a duplicate of 101368 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.