"ABORT: Tear-off objects remain in hashtable at shutdown" with adoptNode

RESOLVED DUPLICATE of bug 761507

Status

()

--
critical
RESOLVED DUPLICATE of bug 761507
7 years ago
6 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, memory-leak, testcase})

Trunk
x86_64
Mac OS X
assertion, memory-leak, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 630059 [details]
testcase (causes fatal assertion during shutdown)

1. Load the testcase
2. Quit Firefox (Cmd+Q)

###!!! ABORT: Tear-off objects remain in hashtable at shutdown.: 'mTable.Count() == 0', file content/svg/content/src/nsSVGAttrTearoffTable.h, line 28
(Reporter)

Comment 1

7 years ago
Created attachment 630060 [details]
stack trace
(Reporter)

Comment 2

7 years ago
Bug 761507 has a similar testcase and a more immediate crash.
Patch in bug 761507 seems to fix this too.
Depends on: 761507
Confirmed that this doesn't hit any assertions or aborts when loading the testcase & quitting, with up-to-date m-c.

Resolving as dupe of bug 761507.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 761507
You need to log in before you can comment on or make changes to this bug.