WebGL graphics not showing on android 4.0 HTC One S phone

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: ia1717, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5

Steps to reproduce:

Opened a simple WebGL demo from scenejs - see http://scenejs.org/dist/v2.0.0/extr/examples/hello-teapot/index.html




Actual results:

Graphics (a teapot rendering) is not shown.  


Expected results:

Graphics should have been shown.  This works in older version of Firefox, and also on Opera Mobile on the same phone.
(Reporter)

Updated

7 years ago
Severity: normal → blocker
OS: Windows 7 → Android
Priority: -- → P1
Hardware: x86_64 → ARM
Severity: blocker → normal
Depends on: 716770
Component: Untriaged → General
Product: Firefox → Fennec Native
QA Contact: untriaged → general
Version: 14 Branch → Firefox 14
This works for me on the Galaxy Nexus on trunk.
Does it work for you with a trunk build?
contextref, what version of Firefox are you using?
(Reporter)

Comment 3

7 years ago
I was using what was available on Google Play as "Firefox Beta", which says 14.0 under Settings | About.  I just tried the nightly build (http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/en-US/fennec-16.0a1.en-US.android-arm.apk), and that one indeed works fine.  Hope the fix will make it to official Beta soon.  Thanks.
OK. This is likely fixed by some of the context changes we have recently landed in beta. Please keep us up-to-date if this isn't fixed with the next beta update!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.