If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash on tooltip callback

VERIFIED INVALID

Status

()

Core
XUL
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Alan Shields, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
HashTableLookup is crashing repeatedly on lookup. I've tried reproducing 
it, but haven't been able to. However, it happens VERY regularly.

I've looked at MacsBug logs, and the last thing on the return stack is 
HashTableLookup. Looking at the code being called by 
HashTableLookup, I'd make a pretty safe bet on the problem lying in 
HashTableGetKey 
(http://lxr.mozilla.org/mozilla/source/rdf/opendir/hash.c#45).

I believe the problem could be related to the fact that GetKey does no 
checking on the parameters given. No null pointer check, etc. If we put this 
in, I think we'll get some better error messages than "unmapped 
memory".

I've attached a StdLog from Macsbug. I'll attach another one for 
comparison when Mozilla crashes again (yes, it's that predictable).
(Reporter)

Comment 1

17 years ago
Created attachment 30999 [details]
StdLog-1

Comment 2

17 years ago
Not sure why component == RDF? Looks like XUL popup stuff based on the stack trace.
Assignee: waterson → trudelle
Component: RDF → XP Toolkit/Widgets
QA Contact: tever → jrgm

Comment 3

17 years ago
Actually, you were looking at the possible return addresses on the stack. 
The more relevant thing in this case is the actual backtrace: 

Calling chain using A6/R1 links
Back chain  ISA  Caller
00000000 PPC 3F5076D0  
0A8F6690 PPC 3F4F2FA0 main+00130
0A8F6630 PPC 3F4F217C main1(int, char**, nsISupports*)+009F8
0A8F6320 PPC 3E971CE8 nsAppShellService::Run()+00018
0A8F62E0 PPC 3E7A7260 nsAppShell::Run()+00048
0A8F6290 PPC 3E7A79AC nsMacMessagePump::DoMessagePump()+0003C
0A8F6240 PPC 3E7A7FBC nsMacMessagePump::DispatchEvent(int, EventRecord*)+0014
0A8F61F0 PPC 3E7BBDA4 Repeater::DoIdlers(const EventRecord&)+00030
0A8F61B0 PPC 3E7BC1E4 nsTimerPeriodical::IdleAction(const EventRecord&)+00014
0A8F6170 PPC 3E7BC58C nsTimerPeriodical::FireNextReadyTimer()+0003C
0A8F6130 PPC 3E7BC3A8 nsTimerPeriodical::FireAndReprimeTimer(nsTimerImpl*)+00
0A8F60E0 PPC 3E7BD0A0 nsTimerImpl::Fire()+00024
0A8F60A0 PPC 3E2E2BE4 XULPopupListenerImpl::sTooltipCallback(nsITimer*, 
void*)+000EC
0A8F5F10 PPC 3E2E2850 XULPopupListenerImpl::LaunchPopup(int, int)+00A10
0A8F5880 PPC 3DD5BC4C 
CreatePopup__19nsPopupSetBoxObjectFP13nsIDOMElementP13nsIDOMElementiiPCwPCwPCw+
00084


Can you detail how this happens. You note that 'you can't reproduce' but it 
happens 'regularly'. Is there some specific action (perhaps related to showing
a tooltip) that you are doing when this occurs?

Updated

17 years ago
Summary: HashTableLookup crashes with unmapped memory exception → crash on tooltip callback

Comment 4

17 years ago
->pinkerton
Assignee: trudelle → pinkerton
(Reporter)

Comment 5

17 years ago
Okay, I feel like a complete moron now. Of course, Moz crashes with this exact error for a week, then stops. Maybe some website I was going to changed their code. I have no clue. I haven't changed my surfing patterns significantly.

I can't reproduce this at all, so I'm going to go ahead and close it out so it doesn't waste any more time. Gaaah. If it recurrs, I'll finesse it a bit, THEN reopen the bug.

Thanks for your time, guys.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
Sounds good. If you can figure out how to make this happen, then do reopen
this bug. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.