Content offset when combining letter-spacing and display: inline-block

RESOLVED DUPLICATE of bug 1224669

Status

()

defect
RESOLVED DUPLICATE of bug 1224669
7 years ago
4 years ago

People

(Reporter: jon, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

7 years ago
Have two levels of display: inline-block with letter-spacing: -4px to counteract the natural spacing between inline elements. The content of the second level is offset by the amount of whitespace "removed".

Bug example here: http://jon.thesquareplanet.com/inline-block-bug/

Bug is also present in Webkit, but Opera seems to handle it correctly.
Reporter

Comment 1

7 years ago
Possibly the same as this Webkit bug: https://bugs.webkit.org/show_bug.cgi?id=69072
OS: Linux → All
Version: 12 Branch → Trunk
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
AFAICT, this is fixed in bug 1224669; the problem illustrated by the testcase here no longer reproduces on current Nightly.

As such, duping this forward to the bug where the patch landed.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224669
You need to log in before you can comment on or make changes to this bug.