"+" button does not show keyboard focus highlight

NEW
Unassigned

Status

()

defect
7 years ago
3 years ago

People

(Reporter: jsilva, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5

Steps to reproduce:

1. Installed Nightly build of Fennec (June 5, 2012)
2. Installed Tecla Access app (provides keyboard & switch access to ppl. w/mobility impairments): https://play.google.com/store/apps/details?id=ca.idi.tekla&hl=en
3. Tested with Tecla Access as default IME with "Show navigation keyboard" option checked.


Actual results:

When the keyboard focus highlight was visible in other controls (highlights are inconsistently shown, see https://bugzilla.mozilla.org/show_bug.cgi?id=761673), I tried to move to the "+" sign. The widget responds to keyboard input but does not show a focus highlight. Therefore, switch/keyboard users may be puzzled since they don't know the focus has moved correctly to the "+" sign as they intended.


Expected results:

The "+" sign on the top-right corner should show a consistent, unambiguous well contrasted highlight when receiving keyboard focus.
Component: General → IME
OS: Linux → Android
QA Contact: general → ime
Hardware: x86_64 → ARM
Jorge, how did you move to the + sign?  I'm not sure I understand how tecla works and how you move from one chrome element to another.
(Reporter)

Comment 2

7 years ago
When testing with the Tecla IME, make sure the "Show navigation keyboard" option is checked so the navigation keyboard is shown.
(Reporter)

Comment 3

7 years ago
Naoki, first you need to make sure the "Show navigation keyboard" option is checked under the Tecla Access settings so that the navigation keyboard is show at the bottom of the screen as this attachment shows: https://bugzilla.mozilla.org/attachment.cgi?id=631089

You will also note that the attachment image shows a faint orange highlight around the address bar. If I was to press the right arrow, the keyboard focus would move to the '+' sign. Then if you press 'OK' on the keyboard, you will have activated the widget.

If you can't see the highlight at all, you can still press the UP arrow a bunch of times and then the RIGHT arrow a couple times. That will put the highlight right at the top-right corner (i.e., on the '+' sign) and you will be able to activate it pressing 'OK'.

I should also note that it is quite hard to get the highlight to appear. This, I suspect is related to https://bugzilla.mozilla.org/show_bug.cgi?id=761673

I will upload another shot showing the highlight on one of the top sites widgets since that one is easier to see.
(Reporter)

Comment 4

7 years ago
Note that I am pressing on the keyboard while taking the screenshot. I suspect the difficulty in bringing up the highlight may reside in the fact that this is a 'button pressed' highlight instead of a 'focus' highlight.
(Reporter)

Comment 5

7 years ago
For additional details on developing for switch accessibility as well as associated benefits visit:
http://komodoopenlab.com/tecla/developers/tecla-for-android-developers/
Ok.  I understood the IME part, I wasn't sure how you were navigating.  The IME settings of "Show navigation keyboard" and restarting fennec was the tip I needed.  Thanks for the info and the bug.

Tecla + Fennec 6/6/2012 Nightly on Samsung galaxy S II
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.