Check and possibly fix RabbitMQ stats in Ganglia (at least PHX1)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: bburton, Assigned: ashish)

Tracking

Details

(Reporter)

Description

7 years ago
In reviewing https://ganglia-phx1.mozilla.org/ganglia/?c=addons-dev&h=celery-dev1&m=cpu_report&r=hour&s=descending&hc=4&mc=2#metric_rabbit_dev_builder_celery_messages_unacknowledged :ashish and I both noted that a number of the RabbitMQ metrics are empty, this may indicate an issue

Please review the RabbitMQ stats and confirm they are being populated correctly or fix as necessary
(Reporter)

Updated

7 years ago
Blocks: 761663
(Assignee)

Updated

7 years ago
Assignee: server-ops → ashish
(Reporter)

Comment 1

7 years ago
Just wanted to see if this could be looked at soon, as these stats are useful for troubleshooting and capacity planning
(Assignee)

Comment 2

7 years ago
I looked into this earlier today and am still clueless about how/where these metrics are sourced from. There were some pointers to a php file for prod but little else.

CC'ing oremj for halp!
(Assignee)

Comment 3

7 years ago
So, all these graphs are working as intended. I verified the data by running rabbitmqctl and the graphs that are "blank" are indeed only 0. Also, bad/no data would have -nan- instead.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.