If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Editing recurring event changes past event occurences

RESOLVED DUPLICATE of bug 320178

Status

Calendar
General
RESOLVED DUPLICATE of bug 320178
5 years ago
5 years ago

People

(Reporter: Mike Greene, Unassigned)

Tracking

Lightning 1.4

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.53 Safari/536.5

Steps to reproduce:

I opened a recurring event and changed it to a different time.


Actual results:

I was prompted to edit just "This Occurrence", or "All Occurrences".  The meeting has permanently moved to a different time, so I chose "All Occurrences".  This changed all of these events including ones that are in the past.  The same thing happens if a recurring event is deleted.


Expected results:

In other calendar programs, we would have a 3rd option, to make this change on "All Future Occurrences".  Otherwise, I will have to change all occurrences of this event forever.

Comment 1

5 years ago
"All Occurrences" modifies all occurrences -> correct behavior, no bug.
"All Future Occurrences" -> existing bug 320178.

You can workaround currently only by editing the recurrence rule and setting an until date that ends the repeating event at the specific date (== keep past occurrences unchanged). Afterwards create a new repeating event starting at the specific date (== the changed future occurrences).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320178
You need to log in before you can comment on or make changes to this bug.