apprunner reformats during mouse click on or tabbing to link

VERIFIED DUPLICATE of bug 28212

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 28212
18 years ago
17 years ago

People

(Reporter: Deven Corzine, Assigned: Marc Attinasi)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I'm running mozilla-apprunner.sh under Linux (RedHat 6.0) for the M6 release of Mozilla.

I resized the apprunner window to about 1000x900 pixels.  The navigation center is on the left, on the right the Mozilla homepage (http://www.mozilla.org/) is loaded.  If I click on any text which is NOT a link, nothing happens, as expected.  However, if I click on a link, it reformats the window, including rewrapping lines, and text ends up placed in different locations on the screen.  If the mouse still points to the link, it will load the new page.  (If it somehow points to a different link, perhaps it would load *that* page?)  If the reformatting moved the link so the mouse is no longer on top of the link, then the link is NOT followed.  A second attempt after the reformatting seems to work, although it looks like there might be a slight amount of additional reformatting happening there too, by a pixel or three.  (Not enough to move the link away from the mouse pointer.)

Updated

18 years ago
Assignee: don → rickg
Component: Apprunner → Layout

Comment 1

18 years ago
Rick, this looks like a re-layout problem.  But I don't see it happening on my
build ...

Updated

18 years ago
QA Contact: leger → petersen

Comment 2

18 years ago
petersen, can you reproduce this?

Updated

18 years ago
Assignee: rickg → petersen

Comment 3

18 years ago
Chris -- please do two things: 1) verify this problem exists; and 2) get me a
specific test case. (Both should be trivial for you -- thanks).
(Reporter)

Comment 4

18 years ago
Is there any more information you need from me to reproduce this bug?

Updated

18 years ago
Summary: Linux M6 apprunner reformats during mouse click! → [PP]Linux M6 apprunner reformats during mouse click!

Updated

18 years ago
Assignee: petersen → rickg

Comment 5

18 years ago
With the latest build (6/14), I can't reproduce the problem described.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Since neither our crack QA team nor I can reproduce, I'm marking this
worksforme.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Verifing Works for Me.
(Reporter)

Comment 8

17 years ago
While I no longer see this behavior with a left-mouse-click, I just noticed that

this reformatting behavior occurs with a middle-mouse-click or right-mouse-click

on a link.  It doesn't happen on all pages, but it does happen

on http://www.mozilla.org/ (clicking on the "party" link for example).



I am running under Red Hat Linux 6.1 now, with today's build (2000030409).  This

bug is making it more difficult to use the middle-mouse patch to open a window.

Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

17 years ago
Pierre -- this is likely a dup of another style related bug.
Assignee: rickg → pierre
Status: REOPENED → NEW
(Assignee)

Comment 10

17 years ago
Taking over 1/3 of Pierre's NEW bugs to help reduce his doomage factor
Assignee: pierre → attinasi

Comment 11

17 years ago
Reassigned back to me these bugs that shouldn't have left my list.
Assignee: attinasi → pierre
(Assignee)

Comment 12

17 years ago
I can reproduce this on NT and on Linux, so it looks like it is not a platform 
specific bug. Also, all you have to do is put focus on the link, that causes a 
restyle relow wherein the table is incorrectly sized. You can duplicate this on 
www.mozilla.org by tabbing to the 'party' link (first put focus on one of the 
links on the left, like FAQ Search).

A StyleChangeReflow is being correctly generated due to the focus changing on 
the link. The tables are then reflowing improperly. Karnaze says it may be 
related to bug 29429 and that it is most likely a table bug. Since it is a 
table-related style bug it is being reassigned to attinasi.
Assignee: pierre → attinasi
Summary: [PP]Linux M6 apprunner reformats during mouse click! → apprunner reformats during mouse click on or tabbing to link

Updated

17 years ago
Blocks: 28522

Comment 13

17 years ago
This bug is probably a dup of bug 28212. CCd karnaze who is working on it.
I also marked this bug as dependent of bug 28522. See comments there.

Comment 14

17 years ago
There's another good example of this bug on freahmeat.net, When you click on any 
of the links under "linux.com partner" the table shifts to the left. 

This bug IS in win32 too.
(Assignee)

Comment 15

17 years ago
Setting milestones and accepting bugs
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 16

17 years ago
*** Bug 31327 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
*** Bug 29723 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
*** Bug 29877 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
*** Bug 30047 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 20

17 years ago
When a link gets the focus border it causes a reflow because the style for the 
spacing has changed. This is due to our use of borders as outlines I think. At 
any rate, the relow is wasteful (there is a bug on it, bug 28522) however the 
subsequent layout is wrong.

Bug 28212 is the same as this one, and karnaze is working on it, so I'm marking 
this a dup of that one.

*** This bug has been marked as a duplicate of 28212 ***
No longer blocks: 28522
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 21

17 years ago
cleaning up: VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.