Last Comment Bug 761717 - Right Indent button looks like the Left Indent button in the Compose window
: Right Indent button looks like the Left Indent button in the Compose window
Status: VERIFIED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: Thunderbird 17.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 11:18 PDT by Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Modified: 2012-08-21 17:19 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (656 bytes, image/png)
2012-06-05 11:18 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details
patch (1.39 KB, patch)
2012-08-13 12:13 PDT, Richard Marti (:Paenglab)
bugs: review+
bugs: ui‑review+
Details | Diff | Splinter Review

Description Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-05 11:18:56 PDT
Created attachment 630234 [details]
Screenshot

See screenshot. Reproducible in Thunderbird 12.0.1 (Ubuntu bundled), 13.0 (official), and 16.0a1 Nightly.
Comment 1 :aceman 2012-06-06 05:22:14 PDT
Bwinton, Andreas, any idea where do these icons come from? I could not see them in the format-buttons.png of gnomestripe theme. But i qute (windows) the icons for indentation are in that file. Do they come from the system (gnome) theme on linux?
Comment 2 Richard Marti (:Paenglab) 2012-06-06 05:34:07 PDT
Could this be a Linux icon theme problem I'm not seeing wizh my Linux icon theme? This icons are coming from GTK

http://hg.mozilla.org/comm-central/file/e622ef230d64/mail/themes/gnomestripe/mail/compose/messengercompose.css#l398
and
http://hg.mozilla.org/comm-central/file/e622ef230d64/mail/themes/gnomestripe/mail/compose/messengercompose.css#l405
Comment 3 Richard Marti (:Paenglab) 2012-08-13 06:02:51 PDT
Anthony, do you still see this behavior?
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-13 09:47:34 PDT
(In reply to Richard Marti [:paenglab] from comment #3)
> Anthony, do you still see this behavior?

Yes. Ubuntu 12.04 64-bit, Thunderbird Daily 17.0a1 2012-08-11.
Comment 5 Richard Marti (:Paenglab) 2012-08-13 12:13:20 PDT
Created attachment 651499 [details] [diff] [review]
patch

Anthony, you're right. I have now a totally unpatched Ubuntu 12.04 and can see your problem. My old Ubuntu always showed the icons correct with gtk-unindent-ltr and gtk-unindent-rtl. Now with unindent and intent it works on both Ubuntus.

Andreas, I hope you have a non-Ubuntu system to check if the icons are still working.
Comment 6 Andreas Nilsson (:andreasn) 2012-08-20 04:29:32 PDT
I didn't see any regressions on Fedora 17 (also GTK+ 3.4), so we should be good. Going to look into the deeper cause a bit, but it works for us regardless it seems.
Comment 7 Andreas Nilsson (:andreasn) 2012-08-20 04:30:46 PDT
Comment on attachment 651499 [details] [diff] [review]
patch

Also worked well when I tried the Force RTL, so I think we're good.
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-20 14:00:17 PDT
https://hg.mozilla.org/comm-central/rev/e6254541c435
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-21 17:19:12 PDT
Verified fixed with Thunderbird 17.0a1 2012-08-21.

Note You need to log in before you can comment on or make changes to this bug.