Excessive background data usage

RESOLVED DUPLICATE of bug 736602

Status

()

defect
RESOLVED DUPLICATE of bug 736602
7 years ago
3 years ago

People

(Reporter: mozilla_bugzilla, Unassigned)

Tracking

(Blocks 1 bug)

14 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 +, fennec16+)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120424151728

Steps to reproduce:

After noticing huge data usage from Firefox 14 beta I did a few tests:

Leave one about:blank tab opened for one hour: no data consumption
Went to http://images.google.com searched for France and left opened for one hour: no foreground data usage but 180 Mb of background data usage

This is just one site. I have noticed it with a lot of different sites: since the beginning of just in a little less than 5 days FF has used 625 Mb of background data and is from far the #1 app for data usage.
real user agent is: Mozilla/5.0 (Abdroid; Mobile; rv:14.0) Gecko/14.0 Firefox/14.0
OS: Linux → Android
Hardware: x86_64 → ARM
Version: unspecified → Firefox 14
Were you signed into Google? I see multiple GET requests probably heartbeat type notifications going to Google Plus when idling on Google Images. What do you get after an hour idling on a basic site that does nothing after it's loaded, i.e., (https://wiki.mozilla.org/Main_Page)
Also did you have sync installed?  Or possibly a flash video in background?
I was not signed in to Google. I do not have Sync setup. No flash video was running in the background.

I tried on (https://wiki.mozilla.org/Main_Page) and did not see any background usage.

On the other hand, I tried the same websites that consume a lot of data in the background with Firefox using the default Internet browser and Chrome and I do not see such a usage.

The workaround I use for now (which I use also because of the battery consumption issue) is to force close Firefox each time I am done browsing. When left alone FF should not consume data (or at least not that much).
This behaviour could result in significant financial charges to users on limited-data plans, so nom'ing as a release blocker even though it's still unconfirmed.
blocking-fennec1.0: --- → ?
I am running a debug trunk build with the DDMS network traffic tab open on Google Images searched for "France" as reported in comment #0. I will report back in an hour with my findings.
After an hour idle; Nightly has not used more than 8.71MB of foreground and 27.93KB background data.
if we can get STR we'd be very interested, so please renom.

Special request to QA to please keep banging on this
tracking-fennec: --- → 16+
blocking-fennec1.0: ? → -
Keywords: qawanted
Kevin/Naoki/Tony, able to give an hour run with a sim-card? Make a difference?
you can also try with this test page which just re-requests itself via XHR every second. http://people.mozilla.org/~kgupta/bug/761731.html
Keywords: qawanted
After an hour idle on the above URL, I have amassed a total of 2612153 bytes ~ 19.9MB.
Re-noming based on comment 11, since we now have STR.
blocking-fennec1.0: - → ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
qawanted to test bumping the throttling to 15 minutes
Keywords: qawanted
Since we are changing the timer throttle, let's dupe to bug 736602
Status: NEW → RESOLVED
blocking-fennec1.0: ? → +
Closed: 7 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 736602
This is not really resolved, this hit me a week back, if I didn't have alerts set up, it would eat all of my data plan:
http://imgur.com/zzzK8Wb

This made me go back to Chrome, as I cannot see a reason for the browser to download something in the background.
This is not resolved. I turned off my phone screen, leaving a google search open in a tab, and background data ate half my data plan in 20 mins. I only found out when I noticed my phone was getting hot in my pocket.

So tell me, why is FF even allowed to run at all, when the screen is off?

Note that I have forced Firefox to never use mobile versions of sites, and that includes changing the user agent to a desktop version. If you want a repro, make sure you browse the desktop version of Google.
Thanks for your recent reports. We have a meta bug tracking issues related to excessive background use:
https://bugzilla.mozilla.org/show_bug.cgi?id=1253346

Could you file a new bug with any specific steps to reproduce? One of the main challenges with these issues is that they're hard to debug, without knowing what specific things are using data.
Yeah I kind of knew it should be a new bug. I'll attempt a repro in two weeks when my data cap resets, and post the bug then.

Given the seriousness of this behavior, I'm willing to put a debug tool on my phone, or anything else you think might be helpful.
If you have come to this bug because of data usage please file a new bug using this template https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox%20for%20Android&component=General&blocked=1253346 with your best recollection of what you did (what sites were open) before this occurred.

I am attempting to reproduce the steps from comment 16. From my early testing usage is holding steady at around 350 KB.
You need to log in before you can comment on or make changes to this bug.