Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Inline autocomplete suggests unexpected URL

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Typed in "f" in the awesomebar


Actual results:

None of the entries suggested are anywhere need my most visited sites. For example the first entry is http://www.firefoxwithbing.com/ even though that's an site I only visited once many months ago.


Expected results:

The ordering of the suggested URLs should reflect the popularity of sites visited. This is the case in the current stable (v 13), where the awesomebar works really works.

Not sure if this is expected behaviour, but at the moment it doesn't seem to work as none of the sites suggested are useful. Only way to solve it is to set browser.urlbar.autoFill to false.

Possibly relates to https://bugzilla.mozilla.org/show_bug.cgi?id=720266

Comment 1

5 years ago
This is actually a regression as of Firefox 14, which I'm seeing now that I've updated on the beta channel. Setting brower.urlbar.autoFill to false does not fix it in Firefox 14; I'm not sure if the results differ in a newer version.
(In reply to bug.zilla from comment #0)
> Not sure if this is expected behaviour, but at the moment it doesn't seem to
> work as none of the sites suggested are useful. Only way to solve it is to
> set browser.urlbar.autoFill to false.

Sorry, but I don't see a relation, this pref only controls the autofilled value in the inputfield, doesn't have any effect on results in the autocomplete popup.

May you please try safe mode to exclude bogus add-ons? http://support.mozilla.org/kb/safe+mode
Also, do you have a places.sqlite.corrupt file in your profile folder?
Do you use Sync and have an Adroid device with Firefox and Sync setup to sync to your desktop computer?

Comment 4

5 years ago
I don't, at least. I don't sync with my android device and I don't have a places.sqlite.corrupt file. For me, the awesomebar is simply ignoring the frequency of visits and instead is only moving URLs to the top now as I visit them. URLs I've been to before the update to Firefox 14 don't come up at the top of the results where they used to before.
(Reporter)

Comment 5

5 years ago
(In reply to Marco Bonardo [:mak] from comment #2)
> (In reply to bug.zilla from comment #0104)
> > Not sure if this is expected behaviour, but at the moment it doesn't seem to
> > work as none of the sites suggested are useful. Only way to solve it is to
> > set browser.urlbar.autoFill to false.
> 
> Sorry, but I don't see a relation, this pref only controls the autofilled
> value in the inputfield, doesn't have any effect on results in the
> autocomplete popup.
> 
> May you please try safe mode to exclude bogus add-ons?
> http://support.mozilla.org/kb/safe+mode105

Sorry, what I did not mean that the browser.urlbar.autoFill solves the issue.
What I meant to say is that it turns it off which means I only have the normal results with no inline autocomplete.

And yes, tried Safe Mode.
I do not have places.sqlite.corrupt and I do not sync.

Hope this helps.
(Reporter)

Comment 6

5 years ago
Having tested used this feature with the latest release version, I think the issue is now resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.