Last Comment Bug 761785 - Background behind webpages has disappeared
: Background behind webpages has disappeared
Status: VERIFIED FIXED
: regression, uiwanted
Product: Firefox for Android
Classification: Client Software
Component: Theme and Visual Design (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
: Anthony Lam (:antlam)
Mentors:
: 772169 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 14:09 PDT by away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2016-07-29 14:25 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified
+


Attachments
Patch (19.38 KB, patch)
2012-07-26 13:06 PDT, Sriram Ramasubramanian [:sriram]
bugmail: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-05 14:09:40 PDT
On latest m-i and m-c builds the background behind web pages (i.e. what you see in overscroll) doesn't show up, it's just black.
Comment 1 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-05 14:26:52 PDT
So far: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=73783bf75c4c&tochange=5199196b65ec
Comment 2 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-05 14:36:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6b480a66acbc&tochange=a6e5cea1cee8

Sriram, I'm guessing one of your changes in this range killed the background drawable. Note that I'm seeing this on the Galaxy Nexus running ICS.
Comment 3 Sriram Ramasubramanian [:sriram] 2012-06-05 14:58:25 PDT
The new background texture is dark for "behind the pages".
http://blog.mozilla.org/ux/2012/05/visual-reboot-of-firefox-mobile-for-android/ (esp: http://blog.mozilla.org/ux/files/2012/05/firefox_mobile_colours.png )
This is the base for the UI, and I just replaced the background as per what Ian gave me.
Comment 4 Sriram Ramasubramanian [:sriram] 2012-06-05 14:59:15 PDT
This is the changeset (file), that caused the change:
https://hg.mozilla.org/mozilla-central/file/a6e5cea1cee8/mobile/android/base/resources/drawable-nodpi/background.png
Comment 5 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-05 18:09:31 PDT
Oh. Well then.
Comment 6 Peter Retzer (:pretzer) 2012-06-05 22:19:21 PDT
(In reply to Sriram Ramasubramanian [:sriram] from comment #3)
> (esp: http://blog.mozilla.org/ux/files/2012/05/firefox_mobile_colours.png )

But this spec picture shows a gray color for overscroll while the new overscroll color you used is rather black?
Comment 7 Aaron Train [:aaronmt] 2012-06-06 07:45:28 PDT
Sriram, should this have been grey with texture (#575E66)
Comment 8 Ian Barlow (:ibarlow) 2012-06-25 12:39:45 PDT
Yes, it should be a textured grey, but a slightly darker one than what is shown in the specs. 

Sriram, let me know if you need a new image for this.
Comment 9 Aaron Train [:aaronmt] 2012-07-03 17:33:17 PDT
Sriram?
Comment 10 Jeff Muizelaar [:jrmuizel] 2012-07-09 12:28:01 PDT
*** Bug 772169 has been marked as a duplicate of this bug. ***
Comment 11 Peter Retzer (:pretzer) 2012-07-26 09:50:15 PDT
I understand that there are probably more important bugs to fix, but it would be nice if this regression could be fixed before 15 gets out the door. It should be just a swap of one image file AFAICS, right?
Comment 12 Sriram Ramasubramanian [:sriram] 2012-07-26 13:06:34 PDT
Created attachment 646280 [details] [diff] [review]
Patch

This patch fixes it.
Killed 1 image -- increased size of 3 other images :P
All is well! ;)
Comment 13 Sriram Ramasubramanian [:sriram] 2012-07-26 23:58:04 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/8357f094c300
Comment 14 Ed Morley [:emorley] 2012-07-27 08:14:30 PDT
https://hg.mozilla.org/mozilla-central/rev/8357f094c300
Comment 15 Peter Retzer (:pretzer) 2012-07-28 13:24:50 PDT
Thanks a lot for fixing this, Sriram! Will you request approval for Beta and Aurora? :-)
Comment 16 Sriram Ramasubramanian [:sriram] 2012-08-03 14:10:31 PDT
Comment on attachment 646280 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: Black background will be shown behind webpages.
Testing completed (on m-c, etc.): Landed on m-c on 07/27.
Risk to taking this patch (and alternatives if risky): None. Just the resource file name changed.
String or UUID changes made by this patch: None,
Comment 17 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-06 12:05:47 PDT
Comment on attachment 646280 [details] [diff] [review]
Patch

low risk, mobile only, approving.
Comment 18 Sriram Ramasubramanian [:sriram] 2012-08-07 11:34:26 PDT
Pushed to aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/7b8cc0f8691b
Comment 19 Sriram Ramasubramanian [:sriram] 2012-08-07 11:49:58 PDT
Pushed to beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/a32db08b36e6
Comment 20 Adrian Tamas (:AdrianT) 2012-09-27 05:19:47 PDT
Overscroll color is correct on: 

Firefox Mobile 16.0b5 / Firefox Mobile 15
Samsung Galaxy R (Android 2.3.4)

Marking as verified on Firefox Mobile 16 and 15

Note You need to log in before you can comment on or make changes to this bug.