Mp4 playback caused gecko to crash and restart

VERIFIED FIXED in mozilla16

Status

()

Core
Audio/Video
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: onecyrenus, Assigned: cajbir)

Tracking

(Blocks: 1 bug, {crash})

unspecified
mozilla16
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(blocking-kilimanjaro:+, blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 630320 [details]
logcat of gecko crash

I was experimenting with h264 playback. 

people.mozilla.com/~dclarke/index2.html

Upon attempting to play gizmo the second time gecko crashes and restarts. 

I am unsure why we are getting into this state.  It doesn't happen with a simple page that just loads a video tag. However the crash does seem to happen inside the new code, so maybe it is worth a look. 

Attached is the logcat.

Updated

5 years ago
Severity: normal → critical
Keywords: crash
(Assignee)

Comment 1

5 years ago
It happens most often when you play a video on a page, then navigate (or refresh) to another page with a video and play that. Do it a couple of times and then it crashes.
(Assignee)

Updated

5 years ago
Assignee: nobody → chris.double
OS: Mac OS X → Gonk
Hardware: x86 → ARM
(Reporter)

Updated

5 years ago
Blocks: 715784, 759945
(Reporter)

Updated

5 years ago
Blocks: 748351
No longer blocks: 759945
(Reporter)

Updated

5 years ago
No longer blocks: 715784
(Reporter)

Updated

5 years ago
No longer blocks: 748351

Updated

5 years ago
Blocks: 748351
blocking-basecamp: --- → ?
blocking-kilimanjaro: --- → ?
blocking-basecamp: ? → +
blocking-kilimanjaro: ? → +
(Assignee)

Comment 2

5 years ago
Created attachment 630820 [details] [diff] [review]
Fix

Crash is caused by an assertion on codec destruction that checks if the codec has been stopped. Fix was to stop codecs in destructor of plugin.
Attachment #630820 - Flags: review?(eflores)
Attachment #630820 - Flags: review?(eflores) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/717abd8063e2
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/717abd8063e2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [qa+]
(Reporter)

Comment 5

5 years ago
Verified Samsung II running B2G
Status: RESOLVED → VERIFIED
Whiteboard: [qa+]
You need to log in before you can comment on or make changes to this bug.