Install apps with AITC enabled on BID account synced to cloud and switching to FF build without AITC supported, but mozapps supported, causes dashboard to fail to show any apps

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
a month ago

People

(Reporter: jsmith, Unassigned)

Tracking

Details

(Whiteboard: [blocking-aitc+])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Steps:

1. Install the latest nightly build (6/5/2012), launch it, and enable AITC and the myapps dashboard
2. Install an app from the app directory
3. Close Firefox
4. Launch the latest Aurora (6/4/2012)
5. Go to myapps

Expected:

Not a 100% sure what the correct behavior is, but I thought the two apps installed for that BID account should appear, as should be locally stored in the user's registry.

Actual:

The dashboard shows nothing, including not even showing the message advertising that there are no apps installed, go install apps at the marketplace. Installing subsequent apps on this Aurora build results in the dashboard never updating at all.
(Reporter)

Comment 1

7 years ago
Created attachment 630356 [details]
Dashboard - Nothing Shown At All
(Reporter)

Updated

7 years ago
Whiteboard: [blocking-aitc]
(Reporter)

Updated

7 years ago
Whiteboard: [blocking-aitc] → [blocking-aitc+]
I cannot reproduce this. However, navigator.mozApps.mgmt seems to be broken on the release and beta channels, but that's a different bug.

Things work on Aurora, but that's because it has AITC now :)

Jason, can you recheck?
Keywords: qawanted
(Reporter)

Comment 3

7 years ago
(In reply to Anant Narayanan [:anant] from comment #2)
> I cannot reproduce this. However, navigator.mozApps.mgmt seems to be broken
> on the release and beta channels, but that's a different bug.

That's bad, but I can confirm what you are talking about. Can you file a bug on that? I think that's in relation to the include.js not getting referenced for some reason.

> 
> Things work on Aurora, but that's because it has AITC now :)
> 
> Jason, can you recheck?
I filed bug 764347, marking this one as invalid. If the issue re-occurs when that bug is fixed, please reopen.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

7 years ago
(In reply to Anant Narayanan [:anant] from comment #4)
> I filed bug 764347, marking this one as invalid. If the issue re-occurs when
> that bug is fixed, please reopen.

bug 764347 isn't the root cause of the issue. The case I'm talking about is FF 15 vs. FF 16, especially if AITC ends up being enabled in FF 16, but not in FF 15. But desktop webrt is enabled in FF 15, but not in FF 16. I'll retest that path (that's what this bug talks about). FF 14 or earlier has mozapps disabled.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
FF 15 has AITC (even if it's disabled) so I'd be surprised if the bug occurs. If it does, leave this bug open. Otherwise please close it.
(Reporter)

Comment 7

7 years ago
Confirmed that you are correct. I think this issue only happened during the timeframe when Aurora 14 has the mozapps enabled without AITC access - that's not possible anymore though - resolving as invalid.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Keywords: qawanted
Resolution: --- → INVALID

Updated

a month ago
Product: Web Apps → Web Apps Graveyard
You need to log in before you can comment on or make changes to this bug.