Last Comment Bug 761854 - IonMonkey: Assertion failure: [barrier verifier] Unmarked edge: <unknown>, at jsgc.cpp:4508
: IonMonkey: Assertion failure: [barrier verifier] Unmarked edge: <unknown>, at...
Status: RESOLVED FIXED
[jsbugmon:update]
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Linux
: -- major (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
: 765487 (view as bug list)
Depends on:
Blocks: langfuzz IonFuzz
  Show dependency treegraph
 
Reported: 2012-06-05 16:43 PDT by Christian Holler (:decoder)
Modified: 2013-01-14 08:13 PST (History)
8 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase for shell (2.77 KB, text/javascript)
2012-06-05 16:43 PDT, Christian Holler (:decoder)
no flags Details
fix (7.22 KB, patch)
2012-06-27 14:16 PDT, David Anderson [:dvander]
wmccloskey: review+
Details | Diff | Review

Description Christian Holler (:decoder) 2012-06-05 16:43:41 PDT
Created attachment 630364 [details]
Testcase for shell

The attached testcase asserts on ionmonkey revision 2062cc1c4b06 (run with --ion -n -m --ion-eager).
Comment 1 David Anderson [:dvander] 2012-06-27 14:12:51 PDT
This is specifically a bug in how gczeal(4) interacts with IonMonkey, so taking s-s off.
Comment 2 David Anderson [:dvander] 2012-06-27 14:16:20 PDT
Created attachment 637255 [details] [diff] [review]
fix
Comment 3 David Anderson [:dvander] 2012-06-27 15:52:47 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/c47c09bf5775
Comment 4 David Anderson [:dvander] 2012-07-02 17:13:08 PDT
*** Bug 765487 has been marked as a duplicate of this bug. ***
Comment 5 Christian Holler (:decoder) 2013-01-14 08:13:15 PST
A testcase for this bug was automatically identified at js/src/jit-test/tests/ion/bug761854.js.

Note You need to log in before you can comment on or make changes to this bug.