Thunderbird 13 Attachment Window "add" button for attachment services is cut-off

RESOLVED FIXED in Thunderbird 16.0

Status

Thunderbird
Preferences
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Tomcat, Assigned: andreasn)

Tracking

unspecified
Thunderbird 16.0
x86
Mac OS X

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed, thunderbird15+ fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 630474 [details]
cut off button

see screenshot the add "hinzufuegen" button is cut off
(Reporter)

Comment 1

5 years ago
or better its a text overflow :)
mconley: This looks fine on Windows XP. Can you provide more space for the buttons? Eight characters for the label is a very small limit, in my humble opinion.
(Assignee)

Updated

5 years ago
Assignee: nobody → nisses.mail
(Assignee)

Comment 3

5 years ago
Created attachment 631433 [details] [diff] [review]
patch to fix the issue

This removes the flex from the #provider-listing xul, and that seems to do the trick. I added the width to #cloudFileView instead so that we avoid getting screwed by really long provider labels. Unfortunately I could not get text-overflow: ellipsis; working, so really long labels gets cut straight off.
(Assignee)

Updated

5 years ago
Attachment #631433 - Flags: review?(mconley)
(Assignee)

Comment 4

5 years ago
Created attachment 631451 [details]
screenshot of patch in action
Comment on attachment 631433 [details] [diff] [review]
patch to fix the issue

Review of attachment 631433 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #631433 - Flags: review?(mconley) → review+
Component: de / German → Preferences
Product: Mozilla Localizations → Thunderbird
QA Contact: german.de → preferences
tracking-thunderbird13: --- → ?
tracking-thunderbird14: --- → +
tracking-thunderbird15: --- → +
Checked in:

https://hg.mozilla.org/comm-central/rev/64605d5789cc
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 16.0
Comment on attachment 631433 [details] [diff] [review]
patch to fix the issue

[Triage Comment]
I think we should also take this on 13.0.1 as it is a new feature.
Attachment #631433 - Flags: approval-comm-release+
Attachment #631433 - Flags: approval-comm-beta+
Attachment #631433 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/03db7bf5a05a
https://hg.mozilla.org/releases/comm-beta/rev/42e16affd853
status-thunderbird14: --- → fixed
status-thunderbird15: --- → fixed
Fixed for 13.0.1:

https://hg.mozilla.org/releases/comm-release/rev/fec9149ec534
status-thunderbird13: --- → fixed
tracking-thunderbird13: ? → +

Updated

5 years ago
Duplicate of this bug: 760236
You need to log in before you can comment on or make changes to this bug.