OS X: Unity plugin cannot be resized to be larger then original size

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: jonas, Unassigned)

Tracking

11 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

11.34 KB, application/octet-stream
Details
(Reporter)

Description

7 years ago
Created attachment 630491 [details]
Build.zip

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.55.3 (KHTML, like Gecko) Version/5.1.5 Safari/534.55.3

Steps to reproduce:

On an OS X machine, do the following:
-Install Unity plugin
-Go to http://thelo.ca/spinningcube/WebPlayer.html , or open html from attached zip file
-Observe a spinning cube in a unity plugin
-Open Web Console
-Enter this into console:
document.getElementById("unityPlayer").style.width = "900px"


Actual results:

The Unity plugin area is resized to a width of 900, but the rendering area is still constrained to 500 width.


Expected results:

The Unity plugin should render at a width of 900 pixels.

Some comments:
-Resizing to a size smaller then the original size works correctly.
-This works correctly in Safari and Chrome, and in Firefox 6, but got broken in some Firefox release after 6.
-Other CoreAnimation plugins don't show this behavior, so it may be specific to what we are doing in Unity. I haven't figured out anything in our code which affects this behavior, though. We are using the Invalidating CoreAnimation drawing model, and the OpenGL rendering is in a sub layer of the main CoreAnimation layer, which is used to render the loading screen and error messages. Let me know if you need more information.
Component: Untriaged → Graphics
Product: Firefox → Core
QA Contact: untriaged → thebes
Resolving as WONTFIX because we no longer support the Unity NPAPI plugin, or any other NPAPI plugins except Flash, in Firefox 52 (bug 1269807).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.