The default bug view has changed. See this FAQ.

Warning about missing mail-toolbar-small.png file in pinstripe

RESOLVED FIXED in Thunderbird 16.0

Status

Thunderbird
Theme
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: florian, Assigned: Paenglab)

Tracking

Trunk
Thunderbird 16.0
x86
Mac OS X
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird15 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
I see this message twice in my terminal when starting a Mac debug build:

Chrome file doesn't exist: /Users/florian/buildhg/comm-central/obj-tbird/mozilla/dist/DailyDebug.app/Contents/MacOS/chrome/classic/skin/classic/messenger/icons/mail-toolbar-small.png

This file is referenced 3 times in the css files of the Mac theme, but doesn't exist:
http://mxr.mozilla.org/comm-central/search?string=mail-toolbar-small.png&find=pinstripe&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
(Assignee)

Updated

5 years ago
Blocks: 709799
(Assignee)

Comment 1

5 years ago
Created attachment 630630 [details] [diff] [review]
patch

Patch uses the monochrome icons missed to change in Bug 709799.

In Web search the disabled icons are now made with opacity: .5 because the new icons have no disabled state image.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #630630 - Flags: ui-review?(bwinton)
Attachment #630630 - Flags: review?(bwinton)
(Assignee)

Comment 2

5 years ago
Created attachment 630634 [details]
patch in action

Screenshot to help for ui-review. The Web search's forward button is in disabled state. On headerToolbar the tag button on the left is the changed icon (the same as the one on main toolbar).
Comment on attachment 630630 [details] [diff] [review]
patch

Stealing reviews.
Attachment #630630 - Flags: ui-review?(mconley)
Attachment #630630 - Flags: ui-review?(bwinton)
Attachment #630630 - Flags: review?(mconley)
Attachment #630630 - Flags: review?(bwinton)
Comment on attachment 630630 [details] [diff] [review]
patch

Looks right to me - thanks Richard!
Attachment #630630 - Flags: ui-review?(mconley)
Attachment #630630 - Flags: ui-review+
Attachment #630630 - Flags: review?(mconley)
Attachment #630630 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

5 years ago
Comment on attachment 630630 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 709799
User impact if declined: no button icon shown
Risk to taking this patch (and alternatives if risky): low risk. It's only a css change
Attachment #630630 - Flags: approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/451ff2be061c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 16.0
Attachment #630630 - Flags: approval-comm-aurora? → approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/6143d9bc158a
status-thunderbird15: --- → fixed
You need to log in before you can comment on or make changes to this bug.