Page Up/Down not working in tables in contenteditable areas when in an iframe

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: monahant, Unassigned)

Tracking

({testcase})

10 Branch
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 630577 [details]
FF_Page Up-Page Down Table Issue.zip

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.4) Gecko/20100101 Firefox/10.0.4
Build ID: 20120420145309

Steps to reproduce:

When Page Up/Down is pressed within a table cell that is larger in height than the iframe area, and the table cell does not contain much content, Page Up/Down stop working.

1. Save both of the attached html files to the same location and open 'iframe.html' in Firefox.
2. Click into the first line of text in the iframe.
3. Press Page Down. The iframe is scrolled one page down.
4. Press Page Down again.


Actual results:

The iframe does not scroll down the second time. Page Up no longer works either.

The problem seems to be that there is no content in the cell to scroll to at the next page up/down level.



Expected results:

The iframe should have scrolled down another page length. It should find content at the page up/down level to scroll to. In the attached testcase, it could use the content of the adjacent table cell in column 2 for example.

Comment 1

5 years ago
I could still reproduce this issue in Firefox 27.
TB bug 454525 looks same like this, and has reproducable testcase: attachment 337808 [details].
I could only reproduce bug 454525 when Caret browsing (F7) was ON.
Keywords: testcase
Hi,

I haven't managed to reproduce this bug on the latest Firefox release(43.0.4) nor the latest Nightly(46.0a1) using the testcase provided. I was able to PageDown to the bottom of the page and PageUp to the top of it.

Build ID 	20160105164030
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

Build ID 	20160112030227
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:46.0) Gecko/20100101 Firefox/46.0

Could you please try to reproduce this on the latest release(43.0.4) and the latest Nightly (https://nightly.mozilla.org/) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Cipri
Flags: needinfo?(monahant)
Since the reporter didn't provide the requested information the fact that I could not reproduce the issue, I will mark this issue as RESOLVED WORKSFORME. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(monahant)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.