rm enclosing->global() != obj->getParent() check in CallObject::create

RESOLVED DUPLICATE of bug 765956

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 765956
6 years ago
6 years ago

People

(Reporter: luke, Assigned: luke)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js:t])

(Assignee)

Description

6 years ago
If I understand correctly, this isn't necessary with cpg.  Is that right Brian?
I think this check is still necessary for objects in non-compileAndGo scripts, as the initial shape of the object is derived from the script's bindings and those bindings will have a NULL parent for non-CNG scripts.  Of course, with CPG there is no sense in distinguishing CNG vs. non-CNG scripts (given special handling for scripts which can run against non-global, non-scope scopes) so the CNG vs. non-CNG distinction should be removed itself.
To be clear, as is the check does not need to be performed for call objects created in compileAndGo code.
(Assignee)

Comment 3

6 years ago
Ohh, I see.  I didn't realize the role TypeScript::SetScope played in all this.  Gross, so we can rip out pretty much all that stuff with CNG.
Whiteboard: [js:t]
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765956
You need to log in before you can comment on or make changes to this bug.