Closed Bug 762107 Opened 11 years ago Closed 5 years ago

Japanese: AMO/Android first page is partial translated

Categories

(Mozilla Localizations :: ja / Japanese, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: xti, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
Steps to reproduce:
1. Change device's language to Japanese 
2. Open Fennec
3. Go to Menu > Add-ons and tap on AMO shortcut from the top-right of the page

Expected result:
AMO mobile page is properly translated into Japanese.

Actual result:
AMO mobile page is not fully translated (see attached screenshot).
(In reply to Cristian Nicolae (:xti) from comment #1)
> Note:
> https://localize.mozilla.org/ja/amo/translate.
> html?search=Easy+ways&sfields=source&sfields=target.

It's already translated as you linked.
Maybe because it's not submitted into svn and I tried to do it with "Commit to VCS" button on this page:
https://localize.mozilla.org/ja/amo/LC_MESSAGES/edit.html

result will be:
Failed to commit file: [SVN] Error running SVN command '['svn', '-q', '--non-interactive', 'commit', '-m', u'Commit from Mozilla Verbatim by user dynamis@mozilla-japan.org.: 905 of 1681 messages translated (52 fuzzy).', '--with-revprop', u'translate:author=dynamis@mozilla-japan.org <dynamis@mozilla-japan.org>', u'/data/www/localize.mozilla.org/verbatim/pootle_env/Pootle/po/amo/ja/LC_MESSAGES/messages.po']': svn: Commit failed (details follow): svn: File '/addons/trunk/site/app/locale/ja/LC_MESSAGES/messages.po' is out of date 

I guess I should "Update from VCS" first but I heard that when we use "Update from VCS", translated work on verbatim (but not yet in svn) will be lost.

I want keep already translated works.
What should I do?

note: If I have svn access, I can merge manually but I don't have it yet.
If you can fix it with SVN access lets get you that.  You'll need to file a bug: https://wiki.mozilla.org/SVN#SVN_account_for_localizers
(In reply to Wil Clouser [:clouserw] from comment #3)
> If you can fix it with SVN access lets get you that.  You'll need to file a
> bug: https://wiki.mozilla.org/SVN#SVN_account_for_localizers

Could you vouch me in bug 708537?
Target Milestone: --- → mozilla16
Target Milestone: mozilla16 → ---
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.