Firefox's focus when opening a tab from outside

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: François Lecomte, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120603165110

Steps to reproduce:

Opened a tab from another software. (can be an email client or a rss reader)

(for instance, I did it with Canto and Evolution, in a GNOME environment, on Arch Linux)


Actual results:

Firefox opened the tab, and stole the focus from the aforementioned software.


Expected results:

Either :
(1) Firefox opens the tabs and doesn't get the focus (behavior I experienced with Firefox 12 until yesterday using Canto)
(2) Firefox opens the tabs and gets the focus (behavior I am experiencing right now with Firefox 13)
(the change was *not* stated in the release notes)

The problem is, either behavior can be a rather huge problem depending on the user, the second being the problem for me. (see https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/481541 and https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/546969 to have complains from both sides)

After one hour of searching, I couldn't figure a way to change the behavior from one to another, even in about:config. (I may be at fault for not finding it, and in that case I apologize for the time lost)
I do believe this choice should exist. (maybe not in Preferences, but at least in about:config)
This is intended behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: Untriaged → Tabbed Browser
QA Contact: untriaged → tabbed.browser
Resolution: --- → WONTFIX

Updated

6 years ago
Component: Tabbed Browser → General
QA Contact: tabbed.browser → general
You need to log in before you can comment on or make changes to this bug.