Modal Alerts not alway activated, impossible to dismiss them

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P2
blocker
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Dan M)

Tracking

Trunk
mozilla0.9.1
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
some time, I have a modal alert in thewhich it's disable that I cannot close. I have to kill the app!

The easy way to reproduce this problem is to turn on the send progres dialog and send a page without entering a 
recipient.

1) Set the following pref into your prefs.js (your profile should not be currently in use):
     user_pref("mailnews.show_send_progress", true);
2) Start Mozilla (or Netscape 6)
3) Load any page into the browser window
4) Select menu file/Send Page
5) From the message compose window, press the send button (do not enter a recipient)
6) ==> you will have a deactivated Alert on top or behind the progress dialog.

This problem does not affect Mac.
(Reporter)

Comment 1

17 years ago
nominating nsbeta1 as it equivalent to an application freeze. Alo this is blocking me from turning on by default  the 
send message progress dialog (see bug 28348) which is a nsbeta1+
Blocks: 28348
Severity: normal → critical
Keywords: mailtrack, nsbeta1

Comment 2

17 years ago
J-F needs this, moving to blocker severity
Severity: critical → blocker

Comment 3

17 years ago
p2 for mozilla0.9.1
Priority: -- → P2
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 4

17 years ago
I don't undertand why, but the big XPCDOM landing seems to have fixed this (?) 
I'd have sworn beforehand that both the progress dialog and the alert were modal. 
I remember them behaving that way. I see now that the progress dialog was never 
modal.

Everything just seems to be working with today's build. The progress dialog is a 
dependent of the compose window, but not modal to it. The alert window is modal 
to the compose window. All three windows behave as expected, given that 
description. I know this was very broken yesterday. The new code path is very 
similar to yesterday's, and I don't understand how it makes any difference in 
behaviour. Of course there was major slappage all over the tree this morning. 
Maybe I'm not even looking in the right place for the origins of the mystery fix. 
But I can't make it happen at all today. This confuses me. But being unable to 
reproduce it now, I gotta close it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Blocks: 75643
i'm able to dismiss the alert dialog, however the "Sending Messages" dialog
stays up --need to click the close widget of the latter to get rid of it.
however, i don't need to kill the app.

vrfy using 2001.05.31.09 comm bits on winNT, since i was able to dismiss the
dialog[s].
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.