Don't show duplicate information in Account lookup

VERIFIED FIXED in 2012-08-23

Status

P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Assigned: wraithan)

Tracking

2012-08-23
Points:
---
Dependency tree / graph

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 630731 [details]
screenshot

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US/account-lookup/5540398/summary
2. Notice the 'Addresses' section

expected behavior:
We only show the latest address for the user OR at least show only distinct address information.

actual behavior:
We list a lot of duplicate information. See screenshot
The data model is a little weird because we capture payment info per addon not per developer. I can change it to filter out dupes though (and look a little prettier).
Assignee: nobody → kumar.mcmillan
Priority: -- → P3
Target Milestone: --- → 2012-06-14
Target Milestone: 2012-06-14 → 2012-06-21
Target Milestone: 2012-06-21 → 2012-06-28
Target Milestone: 2012-06-28 → 2012-07-12
Blocks: 766201
No longer blocks: 752013
Priority: P3 → P2
Target Milestone: 2012-07-12 → 2012-07-26
Blocks: 766199
Assignee: kumar.mcmillan → xwraithanx
Target Milestone: 2012-07-26 → 2012-08-16
The issue is that the template loops over developer addresses but does not check for duplicates. This can be fixed in the view before getting passed to the template:
https://github.com/mozilla/zamboni/blob/master/mkt/lookup/views.py#L54
https://github.com/mozilla/zamboni/blob/master/mkt/lookup/templates/lookup/user_summary.html#L71
(Assignee)

Updated

6 years ago
Target Milestone: 2012-08-16 → 2012-08-23
(Assignee)

Updated

6 years ago
Target Milestone: 2012-08-23 → 2012-08-16
andym suggests we leave this until we figure out payments. Most cases AddonPaymentData is going away or changing so we can deal with it then.

Here is the code I've written so far with some review comments:

https://github.com/wraithan/zamboni/commit/3ccea8c
(Assignee)

Updated

6 years ago
Target Milestone: 2012-08-16 → ---
(Assignee)

Updated

6 years ago
Target Milestone: --- → 2012-08-23
https://github.com/mozilla/zamboni/commit/28935b8

Will show addresses that differ at all.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
verified at https://marketplace-dev.allizom.org/lookup/user/5540398/summary
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

6 years ago
Created attachment 655114 [details]
verified fixed
You need to log in before you can comment on or make changes to this bug.