Last Comment Bug 762395 - Rename "Responsive Mode" to something more sensible
: Rename "Responsive Mode" to something more sensible
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 749628
  Show dependency treegraph
 
Reported: 2012-06-07 00:26 PDT by Dão Gottwald [:dao]
Modified: 2012-08-03 07:27 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
Responsive Design Tool (5.42 KB, patch)
2012-06-08 05:40 PDT, Dão Gottwald [:dao]
dangoor: review-
Details | Diff | Splinter Review
Responsive Design View (5.42 KB, patch)
2012-06-12 02:47 PDT, Dão Gottwald [:dao]
paul: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
Responsive Design (5.41 KB, patch)
2012-06-12 02:48 PDT, Dão Gottwald [:dao]
dangoor: review-
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-06-07 00:26:48 PDT
See bug 749628 comment 64 through bug 749628 comment 67.

Proposed names:

Responsive Design
Responsive Design Tool
Responsive Design Mode
Comment 1 Josh Tumath 2012-06-07 02:23:54 PDT
Other suggestions:

Responsive design viewer
Viewport size tool
Viewport simulator
Screen simulator
Comment 2 Kevin Dangoor 2012-06-07 06:23:45 PDT
Responsive Design View is another option.

These really long names are okay on the menu... but I worry about the developer toolbar, unless we'll have an icon for this feature.
Comment 3 Dão Gottwald [:dao] 2012-06-07 06:29:13 PDT
As the tools add up, you'll probably need icons or some other solution anyway, so I wouldn't worry about it too much now.
Comment 4 Paul Rouget [:paul] 2012-06-07 06:30:28 PDT
> Responsive Design

Maybe. Kevin, what do you think?
(even though I prefer "Reponsive Mode").

> Responsive Design Tool
> Responsive Design Mode
> Responsive design viewer

2 words would be better.

> Viewport size tool
> Viewport simulator
> Screen simulator

It's not a viewport tool, and not a simulator.
Comment 5 Dão Gottwald [:dao] 2012-06-07 06:43:04 PDT
(In reply to Paul Rouget [:paul] from comment #4)
> 2 words would be better.

If we had a good short string, yes. :) But a short string with questionable meaning can be worse than a string that's longer than preferred but also easy to understand.
Comment 6 Dão Gottwald [:dao] 2012-06-07 06:46:42 PDT
(In reply to Dão Gottwald [:dao] from comment #5)
> If we had a good short string, yes.

To be clear, I think "Responsive Mode" is no such string. I'm not sure about "Responsive Design" without Tool/Mode/Helper/whatever.
Comment 7 Rimas Kudelis 2012-06-07 09:29:06 PDT
(In reply to Paul Rouget [:paul] from comment #4)
> > Viewport size tool
> > Viewport simulator
> > Screen simulator
> 
> It's not a viewport tool, and not a simulator.

Paul, can you explain how "Responsive Design tool" is different from a "Viewport size changer"?
Comment 8 Paul Rouget [:paul] 2012-06-07 10:08:04 PDT
(In reply to Rimas Kudelis from comment #7)
> (In reply to Paul Rouget [:paul] from comment #4)
> > > Viewport size tool
> > > Viewport simulator
> > > Screen simulator
> > 
> > It's not a viewport tool, and not a simulator.
> 
> Paul, can you explain how "Responsive Design tool" is different from a
> "Viewport size changer"?

Most of the time, we use the word "viewport" to refer to the viewport meta tag (https://developer.mozilla.org/en/Mobile/Viewport_meta_tag). We are not reading or modifying this tag.
Comment 9 Rimas Kudelis 2012-06-07 10:15:49 PDT
Is that the only reason why the word "Viewport" should not be used here? If so, I'd say you should reconsider. Viewport and Viewport meta tag are two different things.
Comment 10 Paul Rouget [:paul] 2012-06-07 10:27:23 PDT
(In reply to Rimas Kudelis from comment #9)
> Is that the only reason why the word "Viewport" should not be used here? If
> so, I'd say you should reconsider. Viewport and Viewport meta tag are two
> different things.

The viewport meta tag defines the viewport on mobile, we are building a tool that is use for mobile development and lets you change the viewport. People will expect this tool to somehow be related to the viewport meta tag. Way too confusing.
Comment 11 Rimas Kudelis 2012-06-07 10:43:11 PDT
"Responsive Mode" is confusing. "Viewport size changer" is not, at least to me. I must confess that I haven't done too much mobile web development though, and for those who do, the feeling might be different.
Comment 12 Josh Tumath 2012-06-07 12:16:40 PDT
(In reply to Paul Rouget [:paul] from comment #8)
> Most of the time, we use the word "viewport" to refer to the viewport meta
> tag (https://developer.mozilla.org/en/Mobile/Viewport_meta_tag). We are not
> reading or modifying this tag.

Now I see why you said "It's not a simulator". In that case, I can understand your reasoning. But in this context, I think users will understand that something like "Viewport resizer" refers to the initial viewport.
Comment 13 Paul Rouget [:paul] 2012-06-07 12:42:18 PDT
I don't know if "Responsive Mode" is confusing or not, but I sure that people are very confused with what a viewport is.

We won't be using the word "viewport" in the name of this tool.
Comment 14 Dave Camp (:dcamp) 2012-06-07 13:28:01 PDT
If we're planning to rename we should try to get that in before initial release of the tool.
Comment 15 Dão Gottwald [:dao] 2012-06-08 05:40:57 PDT
Created attachment 631359 [details] [diff] [review]
Responsive Design Tool

Not sure if this is the best option, but pretty much anything seems better than the current label, so I'm requesting review to get the ball rolling.
Comment 16 Paul Rouget [:paul] 2012-06-08 05:49:12 PDT
Comment on attachment 631359 [details] [diff] [review]
Responsive Design Tool

This is gonna look huge in the toolbar: http://i.imgur.com/cecIB.png

And if we go for a 3 words label, I'd prefer "mode" rather than "tool".
Comment 17 Kevin Dangoor 2012-06-08 07:51:00 PDT
I understand Dao's issue with the name "Responsive Mode". The mode is not responsive. It's the design/layout that is responsive. On the other hand, the important aspect of this mode and the designs it works with is the "responsive" part. Calling it a "Responsive Mode" does not seem like an unreasonable shorthand. "Responsive Mode" is the name of the mode for working on responsive designs.

I've been trying to come up with a better, shorter name, but without much luck. Wikipedia's article on "responsive web design"[1] uses the abbreviation "RWD". While we *could* use RWD Mode or RWD View, I don't think I've seen the acronym RWD used anywhere in the wild.

I also suggested "Mobile View" to Paul. This is imperfect, especially today when we don't support all of the scaling features necessary to truly emulate the appearance on a mobile device. And, depending on how we grow our mobile emulation features, might even end up being a separate UI from a pure "responsive design view". I do think that most people using this feature will be doing so to see how their pages look on smaller screens, and like the succinctness of "Mobile View", but it is likely too far away from reality.

Paul and Chris Heilmann recently tweeted videos showing off this feature. There were several articles written[2] as a result, and not a single one questioned the name.

In the end, it seems to me that the goal is not to be pedantically correct, but to reasonably communicate what the feature does and who it's for. Early indications are that "Responsive Mode" (at least in the context of web developer tools) does an acceptable job of communicating what the feature is about.

In other words, I don't think we should change the name.

[1]: http://en.wikipedia.org/wiki/Responsive_Web_Design
[2]: http://www.webmonkey.com/2012/06/new-firefox-developer-tools-will-help-you-build-responsive-websites/
http://iloveubuntu.net/firefox-15-nightly-received-two-new-exciting-developer-tools-responsive-mode-and-layout-view
http://www.netmagazine.com/news/firefox-demos-responsive-tool-122005
Comment 18 Dão Gottwald [:dao] 2012-06-08 09:10:50 PDT
(In reply to Paul Rouget [:paul] from comment #16)
> This is gonna look huge in the toolbar: http://i.imgur.com/cecIB.png

See comment 3.

(In reply to Kevin Dangoor from comment #17)
> Paul and Chris Heilmann recently tweeted videos showing off this feature.
> There were several articles written[2] as a result, and not a single one
> questioned the name.

Well, the video works without any language. If you had just said "we have a Responsive Mode now!", you'd probably have got some question marks.

> In the end, it seems to me that the goal is not to be pedantically correct,
> but to reasonably communicate what the feature does and who it's for. Early
> indications are that "Responsive Mode" (at least in the context of web
> developer tools) does an acceptable job of communicating what the feature is
> about.

I filed this bug because I didn't understand the term. It's plain confusing. Call me stupid, but this isn't bikeshedding or being pedantic.
Comment 19 Kevin Dangoor 2012-06-11 09:31:11 PDT
(In reply to Dão Gottwald [:dao] from comment #18)
> See comment 3.

This is a valid point ("icons or some other solution"). A few of us just discussed the fact that we're already there in terms of having too much to try to fit into the toolbar as it stands.

> (In reply to Kevin Dangoor from comment #17)
> > In the end, it seems to me that the goal is not to be pedantically correct,
> > but to reasonably communicate what the feature does and who it's for. Early
> > indications are that "Responsive Mode" (at least in the context of web
> > developer tools) does an acceptable job of communicating what the feature is
> > about.
> 
> I filed this bug because I didn't understand the term. It's plain confusing.
> Call me stupid, but this isn't bikeshedding or being pedantic.

No, I know you're not stupid and wouldn't say such a thing.

The term "responsive design" is still new enough that there are many people that don't know it, including localizers as in the comment that started this discussion.

Let me reframe my view: I do think that "Responsive Design Mode" is better at communicating than "Responsive Mode". This is kind of similar to how "JavaScript Evaluation Notepad" could be seen to communicate better than "Scratchpad".

Someone who doesn't know what "Responsive Design Mode" is can google "responsive design" and immediately get useful results explaining the concept. With just "Responsive Mode", they would google that and likely find a page of ours (probably the MDN documentation for the tool, once that exists) and then possibly go on to read more about responsive design.

In other words, I think "Responsive Mode" is good enough and is ultimately a term that we could define to mean a mode for working on responsive designs.

But, if the length of the name doesn't matter because we're going with icons or have another solution, then "Responsive Design Mode" is going to be more immediately obvious.

I've cc'ed shorlander because he will likely have an opinion on what we'll do with the toolbar and how that impacts the name and whether "Responsive Design Mode" feels too long.
Comment 20 Dão Gottwald [:dao] 2012-06-12 02:47:08 PDT
Created attachment 632179 [details] [diff] [review]
Responsive Design View
Comment 21 Dão Gottwald [:dao] 2012-06-12 02:48:51 PDT
Created attachment 632182 [details] [diff] [review]
Responsive Design

Can we please take one of these patches? I don't care which one. Arguing about /this/ seems like bikeshedding to me...
Comment 22 Kevin Dangoor 2012-06-12 09:09:45 PDT
Comment on attachment 632179 [details] [diff] [review]
Responsive Design View

I have asked shorlander's opinion on this. While he also prefers short names, he thinks that "Responsive Design View" is likely the best choice. It also looks like we have a plan for the developer toolbar so that it won't suffer from having a huge button.

Switching r? over to paul for "Responsive Design View" to make sure he's fine with the code change.
Comment 23 Axel Hecht [pto-Aug-30][:Pike] 2012-06-12 09:24:19 PDT
Do folks have the expectation that we're going to change this on aurora?

As we're already a good deal into the l10n phase of that, also see http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=responsiveUI.label
Comment 24 Dão Gottwald [:dao] 2012-06-12 10:00:00 PDT
(In reply to Axel Hecht [:Pike] from comment #23)
> Do folks have the expectation that we're going to change this on aurora?

I think we should, given bug 749628 comment 64.

> As we're already a good deal into the l10n phase of that, also see
> http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=responsiveUI.label

Apparently people are translating "responsive mode" word-for-word, which seems even more problematic than for en-US, where web devs at least have a chance to relate this to "responsive design".
Comment 26 Matt Brubeck (:mbrubeck) 2012-06-12 18:32:42 PDT
https://hg.mozilla.org/mozilla-central/rev/4215e09508da
Comment 27 Dão Gottwald [:dao] 2012-06-13 04:01:45 PDT
Comment on attachment 632179 [details] [diff] [review]
Responsive Design View

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 749628 (new feature)
User impact if declined: inconsistent naming across releases
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): n/a
String changes made by this patch: yes, see comment 24
Comment 28 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-15 16:08:50 PDT
cc'ing Axel to get final OK on accepting this for Aurora.
Comment 29 Alex Keybl [:akeybl] 2012-06-19 19:41:13 PDT
Pinged Axel over email.
Comment 30 Axel Hecht [pto-Aug-30][:Pike] 2012-06-20 10:47:21 PDT
I'm not fond of this, we should clarify feature names before landing them, really. Like, they shouldn't go to try, to give folks an idea of how early you can start reaching out for issues like this.

I guess this is sucks or sucks, probably sucks a iota less to take it now.
Comment 31 Alex Keybl [:akeybl] 2012-06-24 13:21:49 PDT
Comment on attachment 632179 [details] [diff] [review]
Responsive Design View

[Triage Comment]
Sounds like the sooner the better - approved for Aurora 15.
Comment 33 Ioana (away) 2012-08-03 07:27:14 PDT
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

Note You need to log in before you can comment on or make changes to this bug.