[LAYER] zdnet.com loads page headers and footers, but not the article text.

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
VERIFIED FIXED
19 years ago
3 years ago

People

(Reporter: cpeterso, Assigned: Blake Ross)

Tracking

({testcase, verifyme})

Details

(Whiteboard: [TESTCASE], URL)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: rickg → harishd
Status: ASSIGNED → NEW

Description

19 years ago
Could be an easy kill -- please take a look.

Updated

19 years ago
Assignee: harishd → karnaze

Comment 1

19 years ago
The problem seems to be TABLE  related.  Setting ALIGN value ( a non numeric
string ) causes table to disappear.

Here is the Reduced case:

<HTML>
<BODY>
<ILAYER>
 <LAYER>
  <TABLE ALIGN="LEFT" BORDER=1>
   <TR>
    <TD>
      There
    </TD>
   </TR>
  </TABLE>
 </LAYER>
</ILAYER>
Hello
</BODY>
</HTML>

FYI: The content model looks correct.

Assigning bug to karnaze

Comment 2

19 years ago
In the above testcase, setting align = left|right cause the table to vanish, but
align = center displays properly (M7/Linux).

Updated

19 years ago
Whiteboard: [MAKINGTEST] Antti.Nayha@oulu.fi

Updated

19 years ago
Whiteboard: [MAKINGTEST] Antti.Nayha@oulu.fi

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 3

19 years ago
Verified that this is reduced as much as possible.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9

Updated

19 years ago
Assignee: karnaze → vidur
Status: ASSIGNED → NEW
Target Milestone: M9 → M10

Comment 4

19 years ago
The table is visible in the attachment, but I'm not sure it is correct; when I
remove the layers it looks ok. The url looks very bad, probably due to the
layers. Vidur, if I'm wrong, please reassign to me.

Updated

18 years ago
Assignee: vidur → troy

Comment 5

18 years ago
Yes, this is a layers layout issue, probably related to the LAYER inside the
ILAYER. Assigning to Troy, with the risk that it may be marked WONTFIX or
reassigned to ekrock.

Updated

18 years ago
Assignee: troy → ekrock

Comment 6

18 years ago
Eric, assigning to you.

As I understand it our current policy is to support LAYER and ILAYER but not
with the DOM? I don't see the sense in doing that. We'll still end up with most
pages that use LAYER not displaying correctly

Another issue is what to do about LAYER specific attributes that don't map to
CSS? For example, PAGEX and PAGEY? It's a lot of work to implement that

The third concern I have is that layers aten't compatible with CSS2 positioning.
Things like 'auto' for height don't behave the same. Layers treat that like the
height shrink wraps, but CSS2 doesn't. See the CSS2 spec for details

I think if we're going to do layers then we need to do it right. And that means
someone spending the time to do qualify what that means.
Status: NEW → ASSIGNED
Accepting for now; we're reviewing the question of LAYER and ILAYER.  Agree
completely that there's no point in doing a bad implementation of LAYER/ILAYER,
and that it should be done right or not at all.
Summary: zdnet.com loads page headers and footers, but not the article text. → [LAYER] zdnet.com loads page headers and footers, but not the article text.
Marking [LAYER] in summary.
Target Milestone: M10 → M13
Moving to M13. Want to evangelize site revision to them by beta.  Following up
through Catherine Corre of PR (corre@netscape.com)
*** Bug 15964 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 15896 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 13617 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 16727 has been marked as a duplicate of this bug. ***
*** Bug 16143 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
*** Bug 16728 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
I marked bug 16728. It reported that scrollbar fail to appear for www.zdnet.com.

I tried to load the page, and nothing was drawn on screen. However, I could
still click on things.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
ZDNet has been notified.  Closing this bug and marking INVALID.  We will
doubtless keep getting many DUPs until this is fixed.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 18

18 years ago
Marking as verified invalid

Comment 19

18 years ago
Looks like we'll stop getting hoards of bugs about zdnet and their affiliates.
My 1999121608 WinNT build works fine. So hopefully they fixed their site.
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: ekrock → nobody
Status: VERIFIED → NEW
Component: Layout → Evangelism
Keywords: evangwanted
QA Contact: petersen → nobody
Target Milestone: M13 → ---
Closing all Evangelism bugs where no evangelism is needed because page has been 
fixed, site is internal to Netscape, report is a DUP, or bug report is no longer 
appropriate for evangelism for any other reason.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago

Comment 22

17 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach
(Assignee)

Comment 23

17 years ago
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234
Status: RESOLVED → NEW
(Assignee)

Comment 24

17 years ago
workaround bugzilla problem that caused a bunch of evangelism bugs to be 
NEW/INVALID, NEW/FIXED, NEW/WORKSFORME or NEW/DUPLICATE
Resolution: INVALID → ---

Comment 25

17 years ago
*** Bug 20805 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
This site has been fixed now. Marking fixed. Adding some keywords in the 
interest of tracking.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Keywords: mostfreq, testcase
Resolution: --- → FIXED

Updated

17 years ago
Keywords: verifyme
(Assignee)

Updated

17 years ago
Keywords: evangwanted
verifying
Status: RESOLVED → VERIFIED

Comment 28

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.