Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Disable the chrome debugger menu item until it's ready

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: past, Assigned: past)

Tracking

Trunk
Firefox 16
Points:
---

Firefox Tracking Flags

(firefox15 verified)

Details

Attachments

(1 attachment)

It looks like getting all the pieces for chrome debugging will take a while. We should stop misleading users until that time, by hiding the "Browser Debugger" menu item.
Depends on: 761153
Created attachment 630902 [details] [diff] [review]
Patch

Chrome debugging requires remote debugging by definition, so I added a dependency to the remote flag. When we have chrome debugging working, we can flip the chrome-enabled pref from then on and users can control it from the standard in our developer tools devtools.chrome.enabled pref.
Attachment #630902 - Flags: review?(dtownsend+bugmail)
Attachment #630902 - Flags: review?(dcamp)

Updated

5 years ago
Attachment #630902 - Flags: review?(dcamp) → review+
Attachment #630902 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/integration/fx-team/rev/f6df0a1573e5
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f6df0a1573e5
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 16
Comment on attachment 630902 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Users will have access to a feature that is not ready yet.
Testing completed (on m-c, etc.): ON m-c.
Risk to taking this patch (and alternatives if risky): Riskier not to take it.
String or UUID changes made by this patch: none, but we did add a pref to firefox.js:

+pref("devtools.debugger.chrome-enabled", false);
Attachment #630902 - Flags: approval-mozilla-aurora?
tracking-firefox15: --- → ?

Comment 5

5 years ago
Comment on attachment 630902 [details] [diff] [review]
Patch

[Triage Comment]
Approved for Aurora 15 - are you aware of anywhere this has been communicated and may need to be corrected? I know this wasn't noted for release notes.
Attachment #630902 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/184b0179fb90
status-firefox15: --- → fixed
(In reply to Alex Keybl [:akeybl] from comment #5)
> Approved for Aurora 15 - are you aware of anywhere this has been
> communicated and may need to be corrected? I know this wasn't noted for
> release notes.

I believe this has only been discussed internally so far (including work weeks and weekly calls).
(In reply to Panos Astithas [:past] from comment #7)
> (In reply to Alex Keybl [:akeybl] from comment #5)
> > Approved for Aurora 15 - are you aware of anywhere this has been
> > communicated and may need to be corrected? I know this wasn't noted for
> > release notes.
> 
> I believe this has only been discussed internally so far (including work
> weeks and weekly calls).

also, I don't think the addition of the Chrome Debugger was widely advertised to begin with. We plan on enabling it as a feature in a future version so it's probably not really relnote-worthy.

thanks Alex!
tracking-firefox15: ? → ---

Comment 9

5 years ago
I am verifying this fix on Firefox 15.0 beta 3 but I need some clarifications: after setting devtools.chrome.enabled to true, should there be any visible effect on the debugger? How does the user start debugging chrome?
(In reply to Ioana Budnar [QA] from comment #9)
> I am verifying this fix on Firefox 15.0 beta 3 but I need some
> clarifications: after setting devtools.chrome.enabled to true, should there
> be any visible effect on the debugger?

Nope.

> How does the user start debugging chrome?

Chrome debugging is not implemented yet.

Comment 11

5 years ago
Verified as fixed on:
Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:15.0) Gecko/20100101 Firefox/15.0
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.