Closed Bug 762410 Opened 10 years ago Closed 10 years ago

All images are replaced when new screenshot is added in Edit Listing page

Categories

(Marketplace Graveyard :: Developer Pages, defect, P2)

x86_64
Windows 7
defect

Tracking

(Not tracked)

VERIFIED FIXED
2012-07-26

People

(Reporter: cboldan.mozbugs, Assigned: basta)

References

Details

(Keywords: regression)

Steps to reproduce:
1. Login to Marketplace Dev Hub https://marketplace-dev.allizom.org/en-US/developers/submissions
2. Click on "Edit Listing" link from a listed app.
3. Click the Edit button on the Media section.
4. Add another image/video.

Expected results:
The selected image/video is added among the rest of the images/videos in the media section.

Actual results:
The selected image/video is added and replaces all the other previous added media.

Notes/Issues:
Verified in FF16 Nightly (Win7). Issue is not reproducing in production.
Screencast for this issue http://screencast.com/t/J8mD0b8APM
Keywords: regression
I'm curious what could've caused this.
Assignee: nobody → cvan
Target Milestone: --- → 2012-06-07
Priority: -- → P1
Note that this happens only with accounts which have admin/reviewer privileges.
Regression caused by this: https://github.com/mozilla/zamboni/commit/d4181d1
Priority: P1 → P2
Target Milestone: 2012-06-07 → 2012-06-21
Assignee: cvan → dspasovski
done: https://github.com/mozilla/zamboni/commit/9993f2e
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Now the last added image is replace. You cannot add more than one image when editing the Media section. If you want to add 2 images, the previous one is replaced with the new one.
Please view the screencast http://screencast.com/t/bBWsCkazs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: 766201
No longer blocks: 752013
Target Milestone: 2012-06-21 → 2012-07-05
Can this be fixed for next week's milestone? If not, pass it on to me. Thanks!
Basta, can you take a look at this while I knock out country stores? If you have questions, I sit right next to you.
Assignee: dspasovski → mattbasta
Target Milestone: 2012-07-05 → 2012-07-12
Target Milestone: 2012-07-12 → 2012-07-26
Blocks: 766199
Fixed:

https://github.com/mozilla/zamboni/commit/e44915bc5c51f4a96f1a552607b581c6ac843b01
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Verified as fixed in https://marketplace-dev.allizom.org/en-US/developers/ on FF17 (Win 7)
Postfix screencast http://screencast.com/t/rPmG3TOUS0yw
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.