If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect rendering of page with forms

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: marco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
With Firefox 14, I see incorrect rendering of a page with forms. One of the forms is cut. And when you tap somewhere, Firefox opens links that you haven't touched.
The page is part of Horde (http://www.horde.org/apps/imp), a webmail application.

It's Horde 3.3.5, that is used by many Italian universities and research centers.

In Firefox Mobile, Horde (both the old version and the newest version) doesn't show the mobile frontend, but the desktop one.
I've filed a ticket for Horde: http://bugs.horde.org/ticket/11216
Horde uses framesets, so this is probably because of bug 747493. Marking as a dependency. If you can provide more specific information that would be helpful though - what pages were you seeing the cut forms on, and which links were you trying to click on? I have access to a Horde webmail installation so I can log in to my account there and try to reproduce if you can describe what you're doing in more detail.
Depends on: 747493
(Reporter)

Comment 2

5 years ago
Created attachment 631031 [details]
Screenshot

I see the cut forms on the main page of the Horde webmail application (here, it is "/horde/index.php").
I'm unable to click links in the cut form, like "Inbox".
When I try to pan or click the links in the cut form, sometimes (not always) a link in the left column gets clicked (like the link to go to the Dynamic Mail).

Note that I get these problems in Horde 3.3.5, the new version (that have only the dynamic mail) is working.
Both the old and the new version don't detect Firefox Mobile as a mobile browser, and so they show the classic desktop frontend.
I tried this both on Firefox Beta (14) and a recent m-c build (16), there was some significant difference in behaviour between the two.

On 14: pages are cropped (frameset issue from 747493); pages render as blurry until the first repaint (probably also because of 747493), layout of content is slightly wrong (on some pages only, in the main content frame the top navbar isn't flush against the top of the page, instead it is aligned with the top of the sidebar), and clicking on links often doesn't click on the right spot.

On 16: pages are still cropped (frameset issue), and zooming in behaves like the entire page is fixed-position content. That is, it will zoom in to the top left corner and always display that regardless of where I scroll. The layout of content is still slightly wrong, but clicking on links seems to work fine.

I think the link-clicking issue is a function of scrolling around the page; on 14 it seemed to only get the wrong links when I was zoomed in and scrolled away from the top-left corner of the page. On 16 it never scrolls away from the top-left corner so this isn't an issue.
Adding :Cwiiis. The weird fixed-position-like behaviour is visible even without logging in if you go to http://mywaterloo.ca
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.