Last Comment Bug 762434 - Allow any element to be labelable
: Allow any element to be labelable
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla15
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: 748238 762435
  Show dependency treegraph
 
Reported: 2012-06-07 04:32 PDT by Mounir Lamouri (:mounir)
Modified: 2012-06-20 10:33 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (9.20 KB, patch)
2012-06-07 04:32 PDT, Mounir Lamouri (:mounir)
bzbarsky: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
mounir: checkin+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2012-06-07 04:32:05 PDT
Created attachment 630919 [details] [diff] [review]
Patch
Comment 1 Boris Zbarsky [:bz] 2012-06-07 10:51:21 PDT
Comment on attachment 630919 [details] [diff] [review]
Patch

GetFirstDescendantFormControl should probably be renamed to GetFirstLabelableDescendant.

r=me with that.
Comment 2 Ed Morley [:emorley] 2012-06-08 13:59:13 PDT
https://hg.mozilla.org/mozilla-central/rev/fab542b4877f
Comment 3 Mounir Lamouri (:mounir) 2012-06-12 02:01:07 PDT
Comment on attachment 630919 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: bug fixed by bug 762435 will stay around for 3 months
Risk to taking this patch (and alternatives if risky): this patch alone is pretty safe, it is only moving some logic from a class to another.
String or UUID changes made by this patch: mozilla::dom::Element UUID change
Comment 4 Alex Keybl [:akeybl] 2012-06-15 16:15:44 PDT
(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #3)
> String or UUID changes made by this patch: mozilla::dom::Element UUID change

We typically do not take UUID changes unless we're very confident that there will be no add-on compat or web compat breakage. Can you confirm?
Comment 5 Boris Zbarsky [:bz] 2012-06-15 17:00:47 PDT
There should be no web compat issues from the IID change.

Addons are tougher, but QueryInterface to Element _should_ be pretty rare.  It's a reasonably new class and most ways of getting one do not involve QueryInterface.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-15 17:47:40 PDT
Comment on attachment 630919 [details] [diff] [review]
Patch

Thanks bz, approving in that case.
Comment 7 Mounir Lamouri (:mounir) 2012-06-20 10:33:50 PDT
Pushed in aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/0e385bd36e31

Note You need to log in before you can comment on or make changes to this bug.