Last Comment Bug 762454 - File filtering "@" operator doesn't search for functions
: File filtering "@" operator doesn't search for functions
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 14 Branch
: x86 Mac OS X
: P2 normal (vote)
: Firefox 16
Assigned To: Victor Porof [:vporof][:vp]
:
:
Mentors:
http://addyosmani.github.com/todomvc/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 05:34 PDT by Kevin Dangoor
Modified: 2012-06-15 17:50 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
v1 (3.65 KB, patch)
2012-06-08 02:15 PDT, Victor Porof [:vporof][:vp]
past: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Kevin Dangoor 2012-06-07 05:34:54 PDT
1. open http://addyosmani.github.com/todomvc/architecture-examples/backbone/index.html
2. Type "todos@toggleDon" (don't add the "e", because of bug 762452)
3. it jumps to       "click .check"              : "toggleDone",

Expected result:

should jump to toggleDone: function()

Sublime Text uses @ to jump to functions and # to do a string search. The current behavior is equivalent to Sublime's #.

My suggestion is that we:

1. use "#" for the current behavior, right away
2. use "@" to search for functions, in a followup if need be
Comment 1 Panos Astithas [:past] 2012-06-07 08:03:10 PDT
I think that's a good suggestion. I don't use "#" that much in Sublime, which is why it didn't occur to me earlier. Note that hitting Enter will move to the next match and start from scratch when it reaches the end.
Comment 2 Kevin Dangoor 2012-06-07 08:52:04 PDT
(In reply to Panos Astithas [:past] from comment #1)
> I think that's a good suggestion. I don't use "#" that much in Sublime,
> which is why it didn't occur to me earlier. Note that hitting Enter will
> move to the next match and start from scratch when it reaches the end.

Cool. Somehow I had missed that.

If we could get a switch to # into Aurora, I think that would be preferable to changing the behavior later.
Comment 3 Victor Porof [:vporof][:vp] 2012-06-08 01:59:08 PDT
Let's do a quick switch to #, and tackle the @function search in a followup?
Comment 4 Panos Astithas [:past] 2012-06-08 02:05:06 PDT
(In reply to Victor Porof from comment #3)
> Let's do a quick switch to #, and tackle the @function search in a followup?

Agreed.
Comment 5 Victor Porof [:vporof][:vp] 2012-06-08 02:06:03 PDT
Filed bug 762454.
Comment 6 Victor Porof [:vporof][:vp] 2012-06-08 02:06:16 PDT
(In reply to Victor Porof from comment #5)
> Filed bug 762454.

err.. bug 762825.
Comment 7 Victor Porof [:vporof][:vp] 2012-06-08 02:15:26 PDT
Created attachment 631311 [details] [diff] [review]
v1
Comment 8 Panos Astithas [:past] 2012-06-08 06:11:09 PDT
https://hg.mozilla.org/integration/fx-team/rev/b1338c3c89b2
Comment 9 Tim Taubert [:ttaubert] 2012-06-09 08:39:15 PDT
https://hg.mozilla.org/mozilla-central/rev/b1338c3c89b2
Comment 10 Rob Campbell [:rc] (:robcee) 2012-06-11 10:53:07 PDT
Comment on attachment 631311 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: Users won't be able to search for functions.
Testing completed (on m-c, etc.): on m-c.
Risk to taking this patch (and alternatives if risky): Negligible.
String or UUID changes made by this patch:

Note You need to log in before you can comment on or make changes to this bug.